Three small inconsistencies in Help | About window

Bug #999552 reported by grofaty on 2012-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Adolfo Jayme

Bug Description

Pinta latest development on Ubuntu 12.04. Click on Help | About and you will notice three small inconsistencies:
1. One additional row missing above "Previous Contributors"
2. Some titles have "colon" at the end. Remove colon.
3. No title for Mono icon.

grofaty (grofaty) wrote :
tags: added: easy-to-fix
Cameron White (cameronwhite91) wrote :
Changed in pinta:
importance: Undecided → Low
status: New → Confirmed
Adolfo Jayme (fitojb) wrote :

Sorry, there's no need to add text above Mono icon, it would be redundant. That icon reads "Mono powered", I thought it was obvious. Please, don't change it only for the sake of "consistency".

grofaty (grofaty) wrote :

It looks like a redundant, but what about non-English users?

Adolfo Jayme (fitojb) wrote :

Then add the text, but remove the icon.

But I don't think that's necessary to do. IMO, the icon is obvious enough so every person, regardless of their language, can understand it. Everybody here knows what's a plug, right? You can see the metaphor.

grofaty (grofaty) wrote :

I know a lot of people that do not know any of English words. I also know a lot of people that are not geeks, to know what plug is. I know this is not very important "bug", IMHO, I just thought that any user using any language should have equal understanding when reading About window. My suggestion is:
- title (in bold): Development framework
- text (in normal text): http://www.mono-project.com
- delete icon

Adolfo Jayme (fitojb) wrote :

Excuse me? My grandmother know what a plug is: http://www.electricplug.org/images/electric_plug.png

Grofaty, please forgive me if I sound a little blunt or rude (not my intention at all), but I think you're finding too much superflous "bugs". I agree with you with removing the colons and adding a missing newline, but I think there's no need to mess with the icon, unless you can propose a better one. I wouldn't add a paragraph indicating the development framework, because it adds more visual clutter. Less text = win.

grofaty (grofaty) wrote :

Fitoschido, I agree this is small "inconsistency", don't know if I can call it bug or wish or style preference or something else. But it is not a problem that users do not know what "plug" is (actually there is written "Mono powered" on icon), but it is a problem this is ENGLISH word and NON-ENGLISH speaking person do not UNDERSTAND ENGLISH words written on icon. You know just like it would be written "Mono zitulakapa cirtus". Do you know what "zitulakapa cirtus" means?

I am perfectly aware this is very very very very very tiny problem and that is why I have tagged it with "easy-to-fix" tag and bug is also tagged as Low importance. So this should be changed ONLY (if we agree on the change by itself and) if non of developers/maintainers has anything better to do. Easy-to-fix tag primary intention is for some new developers, to see how development process goes, fixes some easy bug and joins the community. So Low importance/easy-to-fix bugs can be years of not being implemented or even not being implemented at all. So our discussion actually makes this problem 1000-times bigger that it actually is. So constantly replying to this bug report it constantly puts bug into the first place in bug report list. This is my last post in this "bug" report.

P.S. I have no time and no will to discuss what grandma can do or can't do. Involving grandma into discussion and then ask for apology of not intentionally being rude it is actually intentionally being rude by itself. :)

Adolfo Jayme (fitojb) wrote :

Please don't divert the subject.

Robert Nordan (rpvn) wrote :

Guys, you're getting too much emotion mixed in with your opinions. Time to take a step back and relax.

Through the powers vested in me by the community, I declare the following resolution:

- FIx the row inconsistencies.
- Fix the colon inconsistencies by adding them where they're missing because that makes for better English in a context where the statement is followed by a plain list. (Translators can of course choose whether a colon is suitable in their language.)
- Add the text "Powered by Mono" and replace the current Mono-Powered image with a plain Mono image.

This takes into account valid points from both sides, and I consider this to be the end of this discussion.

Adolfo Jayme (fitojb) on 2012-05-17
Changed in pinta:
assignee: nobody → Fitoschido (fitoschido)
Adolfo Jayme (fitojb) on 2012-05-18
tags: added: dialogs
removed: easy-to-fix
Changed in pinta:
status: Confirmed → In Progress
Cameron White (cameronwhite91) wrote :

Pull request has been merged: https://github.com/PintaProject/Pinta/pull/28

Changed in pinta:
milestone: none → 1.4
status: In Progress → Fix Committed
grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments