Uninstallation of Pinta on Windows XP not working

Bug #989275 reported by grofaty on 2012-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Unassigned

Bug Description

I have done several test for bug 956883 and I have found out that Pinta uninstall program is not working for ages - at least from version 1.1 if not before. By the way all Pinta 0.8 and older files are not accessible from: http://www.pinta-project.com/Releases.Old-Releases.ashx I get 404 error from Git which is HTTP error for "File does not exists".

Back to this problem. On Windows XP:
1. From Control Panel I executed Add/Remove programs.
2. Marked Pinta and clicked on Remove button.
3. Uninstall window opens and after confirmation click it appears uninstall is in progress and it finished uninstalling.
4. Looking into path C:\Program files\Pinta and there are all of the Pinta files there. Nothing was deleted.
Work-around: Manually delete Pinta folder from "C:\Program files" parent directory.

Cameron White (cameronwhite91) wrote :

The old versions are now at https://github.com/PintaProject/Pinta/downloads - the Old Releases page hasn't been updated yet.

Cameron White (cameronwhite91) wrote :

Uninstalling worked fine for me with Pinta 1.2 and the latest development preview on Windows 7.

I will test on Windows XP

Cameron White (cameronwhite91) wrote :

Installing and uninstalling Pinta 1.3 preview on Windows XP worked fine for me.

grofaty (grofaty) wrote :

I have rechecked this many times and in my case Pinta just doesn't uninstall. See an attachment for more step-by-step instructions how I uninstalled Pinta.

Cameron White (cameronwhite91) wrote :

Does Pinta still get removed from the Start Menu, etc?

Changed in pinta:
importance: Undecided → High
grofaty (grofaty) wrote :

After uninstalling of pinta-1.3-preview-20120426 on Windows XP I see:
1. Pinta is removed from Add/Remove window.
2. Pinta is removed from Start menu.
3. Pinta is NOT removed from C:\Program files\Pinta
4. Pinta is NOT removed from C:\Documents and Settings\Igor\Application Data\Pinta --> I don't know, this can be intentional not to be removed if Pinta is reinstalled, the settings are preserved.

P.S. I think we can set this settings as Low, if none can reproduce this problem (you have tested and can't reproduce). This can mean it is my system specific. Set is as Low until someone confirms the same behaviour. There is also known work-around - manually removal of files...

Cameron White (cameronwhite91) wrote :

Marking as low since no one else has encountered this yet.

Changed in pinta:
importance: High → Low
grofaty (grofaty) wrote :

Pinta v1.4 on Windows XP, I can still reproduce #6. But leave it at Low priority, because it looks it does not effect any other user then me.

What version of Windows XP are you using? What Service Pack and which edition?

grofaty (grofaty) wrote :

@Geoffrey, I was using Windows XP Professional 32-bit Service pack 3 and several several several Windows updates in years.
I have migrated to Windows 7 (I haven't uninstall any version of Pinta yet - currently I am using the build from source code). But this is probably Windows XP problem and Windows XP are not supported for two mounts and I think we can safety close this bug report as Invalid.

Hello!

It is not Invalid the XP Problem!

With king regards!

grofaty (grofaty) wrote :

I am using Windows 7 now for some time and I am marking this problem as Invalid.

Changed in pinta:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers