Dialog "Could not open file" inconsistent with other Pinta dialogs

Bug #988278 reported by grofaty on 2012-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Unassigned

Bug Description

pinta-1.3-preview-20120425
1. Open text editor and type in some text like: test
2. Save file in text editor, but name it: test.png
Note: I know this is text file, just want to test what happens if I open text file in Pinta.
3. File | Open and mark fake test.png file and click Open.
4. It opens an error message "Could not open file..." (see attachment).
5. This window is also inconsistent with other error dialogs of Pinta.

I suggest:
1. Remote "Error" text from title bar.
2. Write some text above in bold like: "Incorrect image format".
3. Bellow normal text is OK: "Could not open file..."

grofaty (grofaty) wrote :
grofaty (grofaty) wrote :

It looks little bit more complicated. I tried the following on latest development on Ubuntu 11.10:
1. Open Pinta, create some drawing and save file as e.g. test.png
2. Close file in Pinta: File | Close.
2. Open terminal and change user of this file: sudo chown root:root test.png
3. In terminal change permissions of this file: sudo chmod 700 test.png
4. Open file in Pinta: File | Open, mark the file and click on Open button.

I get the same message: "Could not open file: /home/[my_user]/test.png"

It looks like there are multiple possibilities witch have the same error message.
I think we should be more describing when putting "Could not open file..." message. In this case I would like to see:
1. In bold text something like: You don't have a permission to open this file
2. In normal text it is OK to be written: "Could not open file..."

This now looks more to new feature request.

Changed in pinta:
importance: Undecided → Wishlist
milestone: none → 1.4
status: New → Confirmed
grofaty (grofaty) wrote :

I have tested this problem in pinta-1.4-preview-20120908.msi on Windows XP and:
- official report (opening text file on Windows) and
- in answer #2 (opening png file with no permissions on Linux)
in both cases problem still persists.

Cameron White (cameronwhite91) wrote :
Changed in pinta:
importance: Wishlist → Low
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

Tested both cases in the latest version of Pinta on Ubuntu 12.04 and I can confirm this bug is fixed. Thanks a lot.

grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers