No error/warning if pasting non-image

Bug #988243 reported by grofaty on 2012-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Cameron White

Bug Description

pinta-1.3-preview-20120425 on Windows XP:
1. Open text editor and mark some text and copy text to clipboard.
2. Open Pinta and execute <CTRL>+V.
Nothing happens. No error, no nothing. It looks like Pinta is still working and I am waiting for reply. But if pressing <CTRL>+<ALT>+V warning message is displayed: "Paste cancelled..." with is OK. Also the same warning if pressing <CTRL>+<SHIFT>+V.

My suggestion is to put the same message at <CTRL>+V, just like it is at <CTRL>+<ALT>+V and <CTRL>+<SHIFT>+V.

P.S. Probably more enhancement then bug, but for average end-user is important to know what is happening.

Cameron White (cameronwhite91) wrote :

Agreed, this is more of an enhancement but would be nice to fix since it makes Pinta look unresponsive

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
importance: Undecided → Low
milestone: none → 1.3
status: New → Confirmed
Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

Tested on the latest development on Ubuntu 11.10 and it works fine. Problem fixed.

grofaty (grofaty) wrote :

Tested with pinta-1.3-preview-20120426 on Windows XP. Problem fixed. Thanks.

Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers