Memory usage stays large even after image is closed

Bug #987646 reported by Cameron White on 2012-04-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
High
Cameron White

Bug Description

Steps to Reproduce:
1) Open an image (a large image if possible)
2) Resize the image a few times
3) Observe the current memory usage
4) Close the image
5) Memory usage decreases slightly, but remains high

Robert Nordan (rpvn) wrote :

Are you thinking maybe that the canvases from before resizing and/or closing aren't properly discarded?

Cameron White (cameronwhite91) wrote :

Yeah. In particular, it doesn't look like BaseHistoryItem.Dispose() gets called, which would account for some of the memory usage.

Cameron White (cameronwhite91) wrote :

These changes reduced memory usage by about 150-200 MB in my tests: https://github.com/PintaProject/Pinta/commit/062de9fff0129368d4639ede363e94f1e2e06d78

Changed in pinta:
status: New → In Progress
Cameron White (cameronwhite91) wrote :

Fixed an issue with image previews in the Open Images pad not being disposed: https://github.com/PintaProject/Pinta/commit/5cde8074c2f51ef44724588ed1daacddad82c41d

In my test case, Pinta's memory usage now returns from around 415MB to around 120MB after closing my test image (previously it only returned to ~390MB).

Cameron White (cameronwhite91) wrote :

Marking as fix committed since memory usage is now down to a more reasonable level after closing an image.

Changed in pinta:
milestone: none → 1.3
status: In Progress → Fix Committed
Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers