Paint Bucket action can't be undone inside Rectangle Select object

Bug #986932 reported by grofaty on 2012-04-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
High
Cameron White

Bug Description

Pinta 1.2 on Windows, Pinta 1.2 on Ubuntu 11.10:
1. "Rectangle Select" from Tools pallet and marks some area on canvas.
2. "Paint Bucket" from Tools pallet and paint the marked area on canvas.
3. Undo button from toolbar and undo is not working. Expected is to remove paint bucket drawing, but it doesn't.

On the other hand this works fine (witch is similar, but using different tool):
1. "Rectangle Select" from Tools pallet and marks some area on canvas.
2. "Gradient" from Tools pallet and paint the marked area on canvas.
3. Undo button from toolbar and undo works as expected.

grofaty (grofaty) wrote :

Also tested on the latest development on Ubuntu 11.10 and the same problem.

Cameron White (cameronwhite91) wrote :

Confirmed on Windows with latest development version.

I think this in-progress pull request will fix the issue: https://github.com/PintaProject/Pinta/pull/14

Changed in pinta:
importance: Undecided → High
status: New → In Progress
Cameron White (cameronwhite91) wrote :

Looks like this was a regression introduced somewhere between Pinta 1.0 and 1.1

Cameron White (cameronwhite91) wrote :

Fixed: https://github.com/PintaProject/Pinta/commit/a7c831533d36c85242f58bdf70f35752c551b6d1

It wasn't really a regression - it just didn't get exposed until Resize Selection was implemented.

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
milestone: none → 1.3
status: In Progress → Fix Committed
grofaty (grofaty) wrote :

Tested on latest development on Ubuntu 12.04 and problem fixed.

Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers