When layouts.xml fails to load, Pinta crashes

Bug #984044 reported by Robert Nordan on 2012-04-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Cameron White

Bug Description

layouts.xml contains information on window size and position when Pinta was last closed. If it doesn't exist, a new one is created. However, if it does exist but is corrupted or similar, Pinta will crash when trying to read it. Instead, Pinta should catch the errors and recreate layouts.xml.

See this mailing list thread for further references: https://groups.google.com/group/pinta/browse_thread/thread/ea20927cc1be71b3?hl=en (Note that this bug is a general observation unrelated to whatever it is that's causing the corruption in that case.)

Cameron White (cameronwhite91) wrote :

This is not a very common issue, but I'm increasing the importance since it can crash Pinta.

Changed in pinta:
importance: Low → Medium
Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
Cameron White (cameronwhite91) wrote :

Fixed in https://github.com/PintaProject/Pinta/commit/05d2024bb44a03a4c1fba0f4bbb230afd48dbf17.

We still should figure out why the file is being corrupted, but this should at least make things more robust.

Changed in pinta:
milestone: none → 1.3
status: Confirmed → Fix Committed
Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers