Crash when coping part of the images inside Images palette

Bug #956883 reported by grofaty on 2012-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
High
Cameron White

Bug Description

Pinta 1.2-development-update (downloaded from Pinta site found on mailing list) on Windows XP.
1. Make sure Images pallet is visible and docked (View | Tools Windows | Images).
2. If you have some file opened close it down - so no file is opened by Pinta.
3. Paste some image into Pinta with Edit | Paste Into New Image.
4. Repeat step 3 (so you have two exactly the same images - this is for testing purpose).
5. File | New and select 1000 x 1000 pixels.
6. Click on the first image in Images pallet.
7. Edit | Select All.
8. Edit | Copy.
9. Click on third image in Images pallet.
10. Edit | Paste.
11. Click on second image in Images pallet and Pinta crashes.

grofaty (grofaty) wrote :
Cameron White (cameronwhite91) wrote :

I wasn't able to reproduce this crash with the latest development build on Ubuntu 11.10, but I'll try it on Windows and see what happens.

grofaty (grofaty) wrote :
Download full text (3.4 KiB)

I have tried the latest development created from source on Ubuntu 11.10 and the problem is exactly the same.
Notes:
- before step 3 I have created a print screen pressing <Print Screen> key,
- after step 3 there is additional question if I would like to expand canvas, so I selected "Expand canvas" button.

I have run Pinta from terminal. Terminal output is.
*** Start of terminal output ***
Stacktrace:

  at (wrapper managed-to-native) Gtk.Application.gtk_main () <0xffffffff>
  at Gtk.Application.Run () <0x0000b>
  at Pinta.MainClass.Main (string[]) <0x0059b>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

 /usr/bin/mono() [0x80e126c]
 /usr/bin/mono() [0x812046c]
 /usr/bin/mono() [0x805fe7d]
 [0x4002040c]
 /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x2483d3) [0x410723d3]
 /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x23b11a) [0x4106511a]
 /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x23bb90) [0x41065b90]
 /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x252804) [0x4107c804]
 /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x2561c2) [0x410801c2]
 /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x138c52) [0x40f62c52]
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(+0xb68d) [0x4179168d]
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(g_closure_invoke+0x1ac) [0x41792c3c]
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(+0x1f838) [0x417a5838]
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(g_signal_emit_valist+0x589) [0x417ae599]
 /usr/lib/i386-linux-gnu/libgobject-2.0.so.0(g_signal_emit+0x33) [0x417ae8f3]
 /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(+0x272553) [0x4109c553]
 /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(gtk_propagate_event+0xce) [0x40f60eae]
 /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(gtk_main_do_event+0x2c0) [0x40f61240]
 /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0(+0x57888) [0x412ea888]
 /lib/i386-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x1df) [0x4181d25f]
 /lib/i386-linux-gnu/libglib-2.0.so.0(+0x43990) [0x4181d990]
 /lib/i386-linux-gnu/libglib-2.0.so.0(g_main_loop_run+0x14b) [0x4181df9b]
 /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0(gtk_main+0xaf) [0x40f5ffcf]
 [0x441bfb38]
 [0x441bfafc]
 [0x4075d354]
 [0x4075d567]
 /usr/bin/mono() [0x8064afc]

Debug info from gdb:

Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
No threads.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

make: *** [run] Aborted

*** End of terminal output ***

It looks to me like a mono crash. On Windows (see attachment from first post) I also see different window then usual Pinta window crash. On Pinta I have executed "mono --version" command and got output:

***
Mono JIT compiler version 2.10.5 (Debian 2.10.5-1)
Copyright (C) 2002-2011 Novell, ...

Read more...

grofaty (grofaty) wrote :

Just an update, on Windows I use:
- Microsoft .NET Framework 4
- Gtk# for .Net 2.12.10

grofaty (grofaty) wrote :

On Windows I have now uninstalled Gtk# for .Net 2.12.10 and installed Gtk# for .Net 2.12.9-2 as recommended by official Pinta web site. The same crash appears.

grofaty (grofaty) wrote :

On Windows I have also tried to uninstall Gtk# for .Net 2.12.9-2 and installed mono package http://download.mono-project.com/archive/2.10.8/windows-installer/1/mono-2.10.8-gtksharp-2.12.11-win32-1.exe which includes Gtk# 2.12.11 and Pinta even crashes when it starts up.

Cameron White (cameronwhite91) wrote :

OK, I am seeing this crash now on Ubuntu 11.10 with those steps

Changed in pinta:
importance: Undecided → Medium
status: New → Confirmed
Cameron White (cameronwhite91) wrote :

Bumping to high priority.

Changed in pinta:
importance: Medium → High
grofaty (grofaty) on 2012-04-25
summary: - Crash when coping part of the images inside Images pallet
+ Crash when coping part of the images inside Images palette
grofaty (grofaty) on 2012-04-25
tags: added: crash
grofaty (grofaty) wrote :

I did several tests on Windows XP:
1. Uninstalled current Pinta and installed Pinta 1.1. Repeating steps above and Pinta works fine!
2. Uninstalled current Pinta and installed Pinta 1.2-development preview. Repeating steps above and problem appears.
3. Uninstalled current Pinta and installed Pinta 1.2 official release. Problem persists.
4. Uninstalling current Pinta and installed pinta-1.3-preview-20120426.msi. Problem persists.

It looks like this bug is a regression that happened with some update between Pinta 1.1 and Pinta 1.2-development preview. Can you please check what updates where introduced between this two release. I am using multiple pictures and copy/pasting a lot, so this regression makes me cry. ;)

Cameron White (cameronwhite91) wrote :

As far as I can tell, this only happens when switching images by using the Open Images pad (things seem to work fine using the Window menu)

Cameron White (cameronwhite91) wrote :

Looks like this was introduced when image previews were added to the Open Images pad (https://github.com/PintaProject/Pinta/commit/d24ddc12306f62a319fbddd804a93338ecc138bc)

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
milestone: none → 1.3
status: Confirmed → Triaged
Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Triaged → Fix Committed
grofaty (grofaty) wrote :

I tested latest Pinta development on Ubuntu 12.04 and problem is fixed. Thanks.

Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers