Undo after using Move Selected Pixels is broken

Bug #905656 reported by grofaty on 2011-12-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
High
Unassigned

Bug Description

On Ubuntu 11.10 the latest development Pinta version:
1. Click on Rectangle Select button from Tools and mark some area on canvas.
2. Click on Move Selected Pixels and move selected area to some new position.
3. Click on Undo button from toolbar.
Undo is not working. The only visible change is "Finish Pixels" label is added to the bottom of History pad.

It looks like this is a regression made by fix committed on Dec 15 2011 https://github.com/PintaProject/Pinta/commit/38010fcc7c6eea4e499f96c370467143197bc74d which in fact is fixing bug https://bugs.launchpad.net/pinta/+bug/891556 but producing a this reported bug.

I have also tested "latest development version - 1" which is from date Nov 25 2011 https://github.com/PintaProject/Pinta/commit/f54b24ae5dc195418d4048d38863f9316f89166c and undo was working fine using Move Selected Pixels tool so that is why I think this is a regression bug.

Changed in pinta:
importance: Undecided → Medium
status: New → Confirmed
grofaty (grofaty) wrote :

Just a quick update. Tested on Pinta 1.2 on Windows and latest development on Ubuntu 11.10 and problem persists.

Cameron White (cameronwhite91) wrote :
Changed in pinta:
importance: Medium → High
milestone: none → 1.3
Cameron White (cameronwhite91) wrote :

Fixed in https://github.com/PintaProject/Pinta/commit/60ddd224876a83223b7be11a37b122361590580c

I decided to just revert the fix to bug #891556, since that issue was much less severe than this one.

Changed in pinta:
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

Tested in pinta-1.3-preview-20120425 on Windows XP. Problem fixed.

Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers