Pinta freezes when zooming out a very small image

Bug #901712 reported by JOHN_16 on 2011-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

Pinta 1.0
openSUSE linux 12.1

JOHN_16 (john-16) wrote :
Cameron White (cameronwhite91) wrote :

I'm unable to reproduce with Pinta 1.1 - were there any specific things you did before zooming out, such as using a certain tool or brush?

no, i just load image, and use "ctrl" button keyboard and scroll of mouse to zoom out.

i include this image and crash report again

09 декабря 2011, 16:40 от Cameron White <email address hidden>:
> I'm unable to reproduce with Pinta 1.1 - were there any specific things
> you did before zooming out, such as using a certain tool or brush?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/901712
>
> Title:
> Pinta crashes when many times zooming out
>
> Status in Pinta:
> New
>
> Bug description:
> Pinta 1.0
> openSUSE linux 12.1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pinta/+bug/901712/+subscriptions
>

I have tested this issue in Pinta 1.1 on Windows XP and Ubuntu 11.10 (also on the latest development). I don't get any error, but Pinta does freezes in my case. According to the attached picture by john-16 it looks like this got to be some very small picture like 5x5 pixels. I did the following:
1. Open Pinta and click on New icon from toolbar.
2. In New Image dialog type in 5 for both Width and Height and click on OK button.
3. Press <Ctrl> and press "-" many times (in my case 5-times) or scroll mouse wheel to zoom-out the image.
Canvas gets out of control - if you zoom in many times the image on canvas is no more visible. If you switch to some other program and switch back to Pinta the canvas does not get updated. Pinta is in freeze state.

This problem only happens with very small images. It zooms-out and zooms-in with big pictures without a problem.

Don't know if this is the same problem as john-16 I only tested on Pinta 1.1, maybe in older version there is a crash message...

john-16, can you please download Pinta 1.1 and try if this problem behaves like in my case or if it produces the error.
1. Download tar file from: http://github.com/downloads/PintaProject/Pinta/pinta-1.1.tar.gz
2. Open terminal and execute: cd <path_to_your_downloaded_tar_file>
3. tar xf pinta-1.1.tar.gz
4. cd pinta-1.1/
5. ./configure
6. make
7. make run

First check Help | About there should be an info of Pinta 1.1 (so you are running new 1.1 version) and then please recreate the steps that produces the crash. Please also it would be nice if you could provide more detailed step-by-step instructions how you reproduced the problem (something like my steps above). What is your image height and width?

grofaty (grofaty) wrote :

By the way there is no Pinta 1.0 in older releases archive: http://pinta-project.com/download.ashx and select older releases or just click the following link: http://pinta-project.com/Releases.Old-Releases.ashx

The last version in old releases archive is 0.8, so 1.0 is missing (0.9 was never released there was jump from 0.8 directly to 1.0). Administrator, can you please update older releases web page with 1.0 version.

grofaty (grofaty) wrote :

I have installed Pinta 1.0 on Ubuntu 11.10 from official Ubuntu repository (removed PPA) and the problem is the same as in #4, I can't reproduce john-16 problem . The only difference is <ctrl>+mouse wheel does not work (if I am not mistaken mouse wheel was added during 1.1 development cycle), but <ctrl> and "-" key is working, but as described Pinta somehow freezes. After this issue appears, try adding new image 1000x1000 and you will see no image on canvas. So Pinta actually does not freezes, but starts to behave in useless "mode".

i use Pinta from openSUSE repo( rpm package), now a get and install from source 1.1 version - my problem is solve.
thats is good

09 декабря 2011, 21:11 от grofaty <email address hidden>:
> By the way there is no Pinta 1.0 in older releases archive: http
> ://pinta-project.com/download.ashx and select older releases or just
> click the following link: http://pinta-project.com/Releases.Old-
> Releases.ashx
>
> The last version in old releases archive is 0.8, so 1.0 is missing (0.9
> was never released there was jump from 0.8 directly to 1.0).
> Administrator, can you please update older releases web page with 1.0
> version.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/901712
>
> Title:
> Pinta crashes when many times zooming out
>
> Status in Pinta:
> New
>
> Bug description:
> Pinta 1.0
> openSUSE linux 12.1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pinta/+bug/901712/+subscriptions
>

john-16, thanks for update. Developers I still think we should investigate issue from #4 step-by-step instructions, because I still think it is a bug.

Cameron White (cameronwhite91) wrote :

I can reproduce the issue from comment #4 with the latest development build of Pinta, so this is still a bug

Changed in pinta:
importance: Undecided → Medium
status: New → Triaged
summary: - Pinta crashes when many times zooming out
+ Pinta freezes when zooming out a very small image
Robert Nordan (rpvn) wrote :

This was happening because byt a certain point the canvas size was being calculated to less than 1, which is rounded down to 0 as an int. Fixed by enforcing a minimum size of 1 x 1 px for the canvas and not allowing zooming out beyond whatever percentage where that happens.

https://github.com/PintaProject/Pinta/commit/89c3cd20d056e2c6b1340889c4d9d8839d6f8d46

Changed in pinta:
status: Triaged → Fix Committed
Changed in pinta:
milestone: none → 1.2
Robert Nordan (rpvn) on 2012-04-22
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers