Resize tool screen doesn't update canvas after using effects

Bug #892935 reported by Frank on 2011-11-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

By using the resize tool screen, the canvas is not updated. It is necessary to zoom it to be updated.

OS: Ubuntu 11.10 Amd64

grofaty (grofaty) wrote :

Frank, can you please provide more info. What is you operating system and version? What is your Pinta version?
What do you mean by "resize tool screen"? Image | Resize Image or Image | Resize Canvas something else?

Frank (franksouza183) wrote :

Operating system >> Ubuntu 11.10 Amd64
Pinta version >> 1.1

"What do you mean by "resize tool screen"? Image | Resize Image or Image | Resize Canvas something else?"
Resize Canvas, sorry for english

I made a video demonstrating the bug, see: http://www.youtube.com/watch?v=1idjY1J99mc
Go to the 01:02 time and see the bug

grofaty (grofaty) wrote :

Frank, thanks for update.

I tried to create my own simple image and Image | Resize Canvas is working fine (so can't reproduce the problem). But then I tried to follow Frank's instructions as much as possible - it is difficult to draw exactly the same as in video - and I can reproduce the problem (I was testing this problem on Pinta 1.1 on Windows XP sp3). The canvas is not automatically enlarged.

Don't know if this is the same problem or not, but this image I saved and I am attaching it to this report. But the funny thing is I can't open this image anymore with Pinta it produces the error: Could not open file c:\image.png

I tried to open file with:
- Gimp 2.6.11
- Paint.Net 3.5.10
- Microsoft Paint (default Windows XP tool)
- Windows Image and Fax Viewer (default Windows XP tool)
and all this program can open this file except for Pinta 1.1.

It looks one of the effects produces such a file that Pinta can't read it, most probably a bug in Pinta, because all other image editors/viewers can open it.

Changed in pinta:
status: New → Confirmed
grofaty (grofaty) on 2011-11-21
summary: - Resize tool screen do not update canvas
+ Resize tool screen doe not update canvas after using effects
summary: - Resize tool screen doe not update canvas after using effects
+ Resize tool screen doesn't update canvas after using effects
grofaty (grofaty) wrote :

OK, now I have simple step-by-step instructions:

On Windows XP sp3 / Ubuntu 11.10:
1. I have created new image 800x600.
2. Draw something on canvas like e.g. with Paintbrush.
3. Image | Resize Canvas
4. In By percentage window type: 80
5. Ancor click on middle (image) button and click on OK button.
6. Click on Zoom out button from toolbar and canvas now actually gets re-sized.

Cameron White (cameronwhite91) wrote :

Confirmed on Ubuntu 11.10 with Pinta development build.

However, I'm actually able to open the attached image with Pinta on my system.

Changed in pinta:
importance: Undecided → Medium
grofaty (grofaty) wrote :

Cameron, I have tried to open the image from post #3 on:
- Pinta 1.1 on Windows XP sp3: I am getting error "Could not open file c:\image.png"
- Pinta 1.1 on Ubuntu 11.10: opens without a problem
- Pinta latest development on Ubuntu 11.10: opens without a problem

Looks like a Windows specific problem. On Windows I use Gtk# 2.12.10.

Robert Nordan (rpvn) wrote :

It seems basically that the image is resized but the canvas being displayed isn't, so you get sort of an "instant zoom" effet.

Robert Nordan (rpvn) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
Robert Nordan (rpvn) on 2012-04-22
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments