Incorrect behavior of Undo command when editing text

Bug #891556 reported by grofaty on 2011-11-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

Pinta 1.1 on Windows XP sp3 (also tested on Pinta the latest development on Ubuntu 11.10):
1. Select Line object and draw a line on canvas.
2. Select Text object, click on canvas and start typing text like: test
3. Move the mouse over the text and left-click on it and try to move the mouse (I assumed I can move the text to other location, but it looks like text object is not movable).
4. Click Undo button from toolbar and you will see line drawings have been undone instead of Text object drawings.

grofaty (grofaty) on 2011-11-17
description: updated
grofaty (grofaty) wrote :

I can also reproduce the problem without step 3.

The work-around is to click somewhere on the canvas. This makes the exit of editing mode for first text object. It looks like when text is in editing mode, the text object can't be undone.

Cameron White (cameronwhite91) wrote :

A similar issue occurs if you press Ctrl+Z while drawing with the Paintbrush tool.

I think the action of the current tool should be finalized before an undo takes place

Changed in pinta:
importance: Undecided → Low
status: New → Confirmed
summary: - When mouse is used on text undo of text is ignored
+ Incorrect behavior of Undo command when editing text
tags: added: easy-to-fix
Cameron White (cameronwhite91) wrote :

The Undo command now works as expected when editing text:

https://github.com/PintaProject/Pinta/commit/38010fcc7c6eea4e499f96c370467143197bc74d

Changed in pinta:
milestone: none → 1.2
status: Confirmed → Fix Committed
Robert Nordan (rpvn) on 2012-04-22
Changed in pinta:
status: Fix Committed → Fix Released
Cameron White (cameronwhite91) wrote :

Reopening this bug, since the fix was reverted after causing bug #905656 (https://github.com/PintaProject/Pinta/commit/60ddd224876a83223b7be11a37b122361590580c).

The proper fix should be in https://github.com/PintaProject/Pinta/pull/14

Changed in pinta:
importance: Low → Medium
milestone: 1.2 → 1.3
status: Fix Released → In Progress
Cameron White (cameronwhite91) wrote :

The fix is part of a fairly large change, so I'm bumping this to 1.4

Changed in pinta:
milestone: 1.3 → 1.4
Olivier Dufour (olivier-duff) wrote :

I have sent a pull request for that...

grofaty (grofaty) wrote :

Oliver, can you please paste the URL, that we don't lose track of possible fix.

grofaty (grofaty) wrote :

Thanks. I see this fix is already merged into master branch. I have tested it on Pinta latest development on Ubuntu 12.04 and I can confirm this bug was fixed.

Changed in pinta:
status: In Progress → Fix Committed
grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers