Resize Image not accepting default <Enter> action

Bug #889733 reported by grofaty on 2011-11-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Cameron White

Bug Description

Resize Image does not accept default button

Pinta 1.1 on Ubuntu 11.10:
1. New image.
2. Image | Resize Image.
3. Change 100 to 80 (percentage input-box).
4. Now press <Enter>. Nothing happens. It looks like no button (Cancer or OK) has a default action when pressing Enter.

This is probably not a bug, but a feature. But if you look at File | New window you will notice OK button is selected by default and so very easy to just press <Enter> to accept default action.

It would be nice (specially from consistency aspect) to have a default OK button in Resize Image.

grofaty (grofaty) wrote :

Generally it looks like this problem in every window where input-box is selected. But I think <Enter> key is the most important to work when input-box is selected, because changing numbers inside input-box and then pressing <Enter> is very convenient .

So the same problem in:
a) File | Take Screenshot (OK button looks like accepting <Enter> key as default, but pressing it nothing happens).
b) Image | Resize Canvas
c) Layers | Layer Properties
d) Adjustments | Curves
e) Adjustments | Levels
f) Adjustments | Posterize
g) Effects | <all> it looks like when cursor is in input-box it just don't accepts the <Enter> key.
Most probably also in some window I haven't checked.

P.S. This is probably easy to solve hack and also very boring, but it could be solved by some Pinta's newbie developer. To start contributing to the project. Do we have a "easy to fix" tag or something?

Cameron White (cameronwhite91) wrote :

I'll add an "easy-to-fix" tag for these types of issues

Changed in pinta:
importance: Undecided → Low
status: New → Confirmed
tags: added: easy-to-fix
grofaty (grofaty) on 2011-11-13
summary: - Resize Image not acpeting default <Enter> action
+ Resize Image not accepting default <Enter> action
Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
status: Confirmed → In Progress
Cameron White (cameronwhite91) wrote :
Changed in pinta:
milestone: none → 1.2
status: In Progress → Fix Committed
grofaty (grofaty) wrote :

I have tested this solution and it looks like:
d) Adjustments | Curves --> Enter key does not close the window. But in this case I see it is maybe better to have like it is now - to select Transfer Map option from drop-down menu. OK, don't fix this.

e) Adjustments | Levels --> Pressing Enter key does not do any action. It looks you have overlooked this settings. Can you please also add Enter-action to this option.

P.S. I am reopening this bug report.

Changed in pinta:
status: Fix Committed → New
Adolfo Jayme (fitojb) on 2012-02-26
Changed in pinta:
status: New → Fix Committed
status: Fix Committed → New
Cameron White (cameronwhite91) wrote :

In order to add the Enter action to the Levels dialog, we have to use the ActionArea, which forces all of the bottom widgets to be the same width and take up more space (see attached screenshot).

Any opinions on this?

grofaty (grofaty) wrote :

Actually I don't use Levels option. I don't even know what this option is all about (there is also a lack of help to read what is this feature all about). In my humble opinion all of the windows should have the same logic to reduce confusion and make a more professional look of the program.

P.S. Attached screenshot looks good.

Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: New → Fix Committed
grofaty (grofaty) wrote :

I installed Pinta 1.2 on Windows XP and I see this bug is not fixed. For example Image | Resize Image does not excepts the OK button as default button. Also most of other options do not excepts the OK button as default button. Only some of Effects accept OK button.

But on the other hand I have tested Pinta 1.2 (and also the latest development)on Ubuntu 11.10 and OK button is excepted in both cases.

So it looks like Windows specific problem.

Changed in pinta:
status: Fix Committed → New
Cameron White (cameronwhite91) wrote :

It works fine for me on Windows 7 (see attached screenshot)

grofaty (grofaty) wrote :

My system:
- Windows XP sp3,
- Microsoft .NET v4.0 Framework,
- Gtk# for .Net 2.12.9 (official version from www.pinta-project.com)

P.S. Maybe Windows XP specific or some Gtk# problem or something. What is your environment.

Cameron White (cameronwhite91) wrote :

I'm running Windows 7, with Gtk# 2.12.9 and .Net 4.

Sounds like it might be an XP-specific problem?

Changed in pinta:
milestone: 1.2 → 1.3
Cameron White (cameronwhite91) wrote :

I tested on Windows XP in a virtual machine, and the <Enter> action does work properly (see attached).

grofaty (grofaty) wrote :

According to your test on Windows XP, it looks my environment specific. Any idea what I should also check?

Cameron White (cameronwhite91) wrote :

Not sure what the difference could be.

Is this happening for all of the dialogs I fixed this for, or only certain ones?

grofaty (grofaty) wrote :

I have rechecked this bug using pinta-1.3-dev-preview and now I see this as fixed. Strange, was this already fixed in pinta-1.2? Anyway it is fixed now. Thanks!

Changed in pinta:
status: New → Fix Committed
Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers