Selection resize handles are zoomed as well when the image is zoomed

Bug #889723 reported by grofaty on 2011-11-13
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

Pinta 1.1 on Ubuntu 11.10:
1. New image with 45 x 45 pixels.
2. From toolbar zoom to 1200%.
3. Rectangle / Ellipse Select.
4. Mark some area on canvas.
Corners of selection are way way too big. The biggest problem is that it over-hides the image and it is hard to select proper selection.

Most probably Pinta 1.1 regression, because this resize feature was added at v1.1.
See attached picture for sample - notice huge blue corners.

grofaty (grofaty) wrote :
grofaty (grofaty) wrote :

There is also vice-versa problem. On 3000 x 3000 image and using Rectangle Select no corners are visible to resize image. See attachment.

Changed in pinta:
importance: Undecided → Medium
status: New → Confirmed
Adolfo Jayme (fitojb) on 2011-11-13
summary: - Rectangle/Ellipse Select with small zoomed images corners are two big
+ Selection resize handles are zoomed as well when the image is zoomed
Robert Nordan (rpvn) wrote :

A fix has been committed that solves the problem by scaling the nodes when zoom is changed. When zoomed all the way in there will still be a 1x1 px blue square for the handle, but this shouldn't be as much in the way as before.

Changed in pinta:
status: Confirmed → Fix Committed
Robert Nordan (rpvn) wrote :

I had to revert the second commit that updated the node sizes on zooming because it caused exceptions to be thrown when switching images (Which I of course forgot to test), and I don't have time to figure out a better way of doing it. Still marking this as fix commited, because most of the problem is solved. (Whenever you make a new selection it is adapted to the zoom level.)

Good thing I'm concentrating on being more incremental in my git commits!

Changed in pinta:
milestone: none → 1.2
Robert Nordan (rpvn) on 2012-04-22
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers