Open Images pad probably incorrect string name

Bug #886512 reported by grofaty on 2011-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Undecided
Unassigned

Bug Description

Hi,
looking at Pinta 1.1 there is new "Open Images" pad. Using Pinta I have noticed a bad translation that I made, so I was curious why this translation problem appeared and I think because the name in English is not the best one chosen. Correct me if I am wrong - I am not a native English speaker - but word open in "Open Images" string is actually a verb (and it looks like if clicking on it will open a new image, but actually it would just change selected image), but in my humble opinion it should be an adjective like "Opened Images".

I have looked at Paint.net and the string name is a "Image List" (see Window | Show Image List option in Paint.net).

But actually I don't like neither. I think the pad name should be "Images", just like "Layers" - there is no name "Open Layers" or "Opened Layers". In both cases it is obvious layers/images are opened.

Regards

Robert Nordan (rpvn) wrote :

Open can actually be both a verb and an adjective, but I see how there would be translations issues. We either need to change it or to add a translation comment.

Changed in pinta:
status: New → Confirmed
grofaty (grofaty) wrote :

Robert thanks for explaining the verb/adjective usage. Now I have looked at the dictionary and for word open I see it can be used as: verb, adjective, noun and transitive verb (maybe also something else that I didn't find out).

Verb sample: You can open (=verb) an image by using File | Open menu.
Adjective: US has an open (=adjective, like not dictated by state) economy.
Noun: You need to come into the open (noun, like stop hiding).
Transitive verb: They open (=transitive verb, like giving an opportunity) the door to public participation.

Non-English languages that I know of are adding some kind of suffix to the end of the word to distinct when the word is verb, adjective, noun, transitive verb, etc but English simplifies suffix usage which is fantastic when used in sentence, but it is harder to see the real meaning from using just one or two words combined.

In Launchpad Translation I have searched the string: "open image" and got three results:
- Open Image File (open as verb; image as adjective),
- Open Image (open as a verb; image as noun),
- Open Images (open as an adjective; image as plural noun).
Last two strings are specially confusing, because without additional explanation (like looking at the Pinta program itself) it is impossible to know if open is used as verb or adjective.

As I see we have three options:
1. Leave "Open Images" string and add some comment to Launchpad Translation.
2. Change string to "Images List" like Paint.net.
3. Change string to "Images" like string Layers, Palette, Tools, History (non of them has open word).

My humble vote: option 3

Adolfo Jayme (fitojb) wrote :

I vote for option 2 ;)

Robert Nordan (rpvn) wrote :

I vote for option 3, because I think it's sensible to stick to single word descriptions for consistency. And since 66% of the vote so for is for option 3, I went ahead and committed it. ;-)

https://github.com/PintaProject/Pinta/commit/3377b0144bf46a01503dfeac7552aec0b58cd4c5

Changed in pinta:
status: Confirmed → Fix Committed
Changed in pinta:
milestone: none → 1.2
Robert Nordan (rpvn) on 2012-04-22
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers