Pinta completely unusable in Mac OS 10.5.8

Bug #883332 reported by Eiður Þór on 2011-10-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
High
Cameron White

Bug Description

Pinta is COMPLETELY unusable on Mac OS X Leopard (10.5.8). It won't recognize image files as image files in the open dialog and when trying to open anything it CRASHES. When trying to start a new project it CRASHES. When clicking ANY icon in the tool bar it CRASHES. It won't even sometimes close without making it force quit.
I've tried reinstalling Pinta countless times and also reinstalled Mono.

You see I just discovered this application and I can't even imagine how it's possible to release an application with huge bugs like these going unnoticed.

If you want console messages just let me know.

Cameron White (cameronwhite91) wrote :

Could you please attach any console logs?

This is the first report I've seen of issues with earlier versions of Mac OS X (there are some issues with Lion)

tags: added: osx
grofaty (grofaty) wrote :

I also haven't seen any report of such disfunction of mono in OSX Leopard. Most probably some mess in the latest version of Mono. Which version of mono did you download? Can you please try to install older version of Mono from web page: http://mono-project.com/OldReleases like 2.6.7. And if you have time and will we would be very happy if you could also try other versions of mono from 2.6.7 to 2.10.5.

You know Pinta is open-source project and as I know non of developers have access to OSX. So we would really need any kind of help - like testing and reporting bugs.

Can you please start Pinta from terminal and post the errors when Pinta crashes. Can you also post the text (please save them in text files) of error message when Pinta crashes and the action taken when exactly Pinta crashes.

Eiður Þór (eiduur) wrote :

I downloaded the most recent version of Mono for Mac OS X (linked to on Pinta's download page).

Pinta appears to work well with Mono version 2.6.4. So it must be some problem with Mono.

I'm really sorry if you felt like I was being a little aggressive or anything. I do think though that it's necessary to have some testers for every OS you are trying to support.

Console messages are attached (from using the most recent version of Mono).

Robert Nordan (rpvn) wrote :

Well, we'd love to have you onboard as a tester! It's well known that Apple have a habit of breaking stuff with every new release of OS X and it's possible that since the newest Mono is adapted to weirdness in Lion it might have trouble on earlier versions. The more testers we have, the merrier! (And the more knowledge we have written down, the easier it is for newcomers to solve similar problems.)

That being said, Pinta has recently had a change in maintainers and during that transition we lost our core developer who actually had a Mac so we're a bit handicapped. But since Pinta has long offered a Mac edition we're not going to drop it as that would severely dissapoint those of our users who are on Macs. We're doing the best we can and we can at least promise that once you get all the kinks of Mono+Mac ironed out there are fewer of all the non-OS related bugs. ;-)

Eiður Þór (eiduur) wrote :

I'll keep it mind ;) After doing a little tinkering with a project a few problems have surfaced. The open dialog doesn't seem to accept jpegs as image files, (won't appear unless selecting all files) drop downs disappear almost immediately and it crashes when trying to copy or paste from the toolbar.

grofaty (grofaty) wrote :

Eiduur, that is great news, you becoming a tester on Mac OSX. Can you please look at the mailing list https://groups.google.com/group/pinta/browse_thread/thread/156902672356fb27?hl=en to test the new Pinta 1.1 version for Mac OSX that was released yesterday. Please post reply to above link mailing list. If you find any problem, then please report EACH PROBLEM in separate bug report. It is very hard to track all problems in one spaghetti long post. Also write simple step by step instructions how you produced the problem. If there is some file type problem, then also attach the file, that other testers can test the same problem on other OSes.

@Developers, we need to change default download Mono web page from our official Pinta project web page.

Cameron White (cameronwhite91) wrote :

Can you still reproduce these crashes with the Pinta 1.2 alpha build (https://github.com/downloads/PintaProject/Pinta/Pinta-1.2-alpha.app.zip)?

Changed in pinta:
importance: Undecided → High
Eiður Þór (eiduur) wrote :

Unfortunately I still seem to have most of these crashes and other issues with the alpha build. Pinta crashes on creating a new file and doesn't recognize image files. It chrashes upon clicking most icons in the toolbar before opening an image but no problems with using most functions after that. Pinta is also quite unresponsive.

I'm using the last stable version of Mono (2.10.8).

Cameron White (cameronwhite91) wrote :

Thanks for the info.

Could you attach any console logs for those crashes?

grofaty (grofaty) on 2012-04-25
tags: added: crash
Cameron White (cameronwhite91) wrote :

I made a couple more changes to make icon loading more robust: https://github.com/PintaProject/Pinta/commit/e4a996943c76acbe2134a0ca4984b260a964dce2

I think this should fix the issue with Pinta crashing on creating a new file.

Cameron White (cameronwhite91) wrote :

For the toolbar crashes, my best guess is that for some reason Pinta doesn't create the default blank image when it starts up, and some of the toolbar buttons are left enabled. Is that the case for you?

Cameron White (cameronwhite91) wrote :

Fixed an issue with the command-line argument parsing that could lead to the blank image not being created: https://github.com/PintaProject/Pinta/commit/9c231cb97fc898163103e85803fc820827259486

These changes can be tested with https://github.com/downloads/PintaProject/Pinta/Pinta-1.3-preview-20120426.app.zip

Eiður Þór (eiduur) wrote :

Most of these problems seem to have been resolved by now with this newest release, congrats.
There is though one problem that seems to bug me, that is how badly pencil drawing seems to render (also very transparent on images), but that is totally different problem probably best save for later :)
Sorry for the late reply.

Cameron White (cameronwhite91) wrote :

Awesome, glad to hear that these fixes worked!

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
milestone: none → 1.3
status: New → Fix Committed
grofaty (grofaty) wrote :

eiduur, please report "pencil problem" to separate bug report. There should always be "one bug per bug report" to make it simple to manage bug reports. Thanks.

Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers