Extension Manager name and Add-in Manager name not consistent

Bug #873632 reported by grofaty on 2011-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Cameron White

Bug Description

Ubuntu 11.10 / Pinta 1.1 from PPA (package name: 1.1-1ubuntu1).

1. Help | Extension Manager
2. "Add-in Manager" window opens. This is not consistent naming.

There are several names used in other programs like:
- extension,
- add-in,
- plug-in.

Gedit uses "Plugin". I don't have a preferred name, but the names should be consistent.

grofaty (grofaty) wrote :

I have checked the mailing list and I see it was a topic of this opened for discussion, see more:
https://groups.google.com/group/pinta/browse_thread/thread/4269d1bc8ac920ac?hl=en

Changed in pinta:
status: New → Confirmed
grofaty (grofaty) wrote :

Just a quick update. Tested on Pinta 1.2 on Windows and latest development on Ubuntu 11.10 and problem persists.

Cameron White (cameronwhite91) wrote :

I think we should go with "Add-in Manager", since we're using the Mono.Addins library.

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
importance: Undecided → Low
milestone: none → 1.3
grofaty (grofaty) wrote :

I agree with "Add-in Manager". I also suggest to move this "Extension Manager" to the bottom of Edit menu (add new line before this option).

tags: added: addins
Cameron White (cameronwhite91) wrote :

Fixed: https://github.com/PintaProject/Pinta/commit/5d6bcb38c892d975013d690c0e8ad9b2878e0c0d

Switched to using "Add-in Manager", and moved the option to the Edit menu.

Changed in pinta:
status: Confirmed → Fix Committed
Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers