Diacritics not working in text tool

Bug #859082 reported by Adolfo Jayme on 2011-09-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Olivier Dufour

Bug Description

Pinta doesn’t allow to type text with diacritics. All letters with accents or umlauts are displayed without them. This bug is maybe related with bug 776328.

Robert Nordan (rpvn) on 2012-01-21
Changed in pinta:
status: New → Confirmed
importance: Undecided → Low
Adolfo Jayme (fitojb) on 2012-04-29
tags: added: text-tool
grofaty (grofaty) wrote :

I tried to write German umlauts, but instead of letters: ä, ü and ö letters a, u and o are displayed.

grofaty (grofaty) wrote :

Using Pinta latest development on Ubuntu 12.04, now it is fixed copy/paste in Pinta (GitHub commit from 6 of May 2012). And I can copy all of the German umlauts and I can also copy Cyrillic letters. But I still can't type in any of them.

For copy/paste I have used the following web pages:
http://en.wikipedia.org/wiki/Cyrillic --> table on the bottom
http://en.wikipedia.org/wiki/Germanic_umlaut --> first table from "Morphological effects" chapter.

Olivier Dufour (olivier-duff) wrote :

After some investigation, it must be done with gtkimcontext.
It will not some work to make it working properly

Olivier Dufour (olivier-duff) wrote :

pull request sent for that :
https://github.com/PintaProject/Pinta/pull/23
I need some check/feedback

Changed in pinta:
assignee: nobody → Olivier Dufour (olivier-duff)
grofaty (grofaty) wrote :

Just wondering is this a duplicate of bug 776328?

Changed in pinta:
status: Confirmed → In Progress
Adolfo Jayme (fitojb) wrote :

Pull request merged. I've verified the fix and it works like a charm. Thanks, Olivier!

Changed in pinta:
status: In Progress → Fix Committed
Changed in pinta:
milestone: none → 1.4
grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers