Pinta crashes on OS X Lion with the latest GTK#

Bug #846660 reported by agelal on 2011-09-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
High
Unassigned

Bug Description

Looks like something latest GTK# Lion specific. I opened the project in MonoDevelop and when running it, I get 'gtk-close' is not a valid resource. This means for some reason Pinta is not able to use default GTK icons. On Windows it runs just fine.

Tags: osx Edit Tag help
Changed in pinta:
importance: Undecided → High
agelal (ashokgelal) wrote :

The one way of fixing this would be to add own close image instead of relying on underlying gtk. The close icon is available free http://www.iconfinder.com/icondetails/20703/16/close_delete_remove_exit_icon?r=1. If this is okay, I would like to work on a fix for this.

Cameron White (cameronwhite91) wrote :

Just to verify, are you using the latest version of Mono/GTK# (2.10.5)?
It claims to have support for Lion (see http://www.go-mono.com/mono-downloads/download.html), so this is probably something that should be reported upstream to the GTK# developers if that is the case.

Otherwise, yeah, we'll have to add that icon as a workaround since not being able to run Pinta on Lion is a pretty major issue.

agelal (ashokgelal) wrote :

Yes, I'm using the latest version 2.10.5 of GTK#. I agree that this should be notified to GTK# developers but it might take a while before they roll out an update. Meanwhile, we can provide a 'temporary' fix and roll it back once they fix this bug.

agelal (ashokgelal) wrote :

I did more testing and turned out that the matter is more serious than just the 'gtk-close'. I fixed that and now I started getting more errors:

(Pinta:25647): Gtk-WARNING **: Could not find the icon 'gtk-dialog-error'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
 http://icon-theme.freedesktop.org/releases
GLib.GException: Icon 'gtk-dialog-error' not present in theme
  at Gtk.IconTheme.LoadIcon (System.String icon_name, Int32 size, IconLookupFlags flags) [0x00000] in <filename unknown>:0
  at Pinta.ErrorDialog.Build () [0x00000] in <filename unknown>:0
  at Pinta.ErrorDialog..ctor (Gtk.Window parent) [0x00000] in <filename unknown>:0
  at Pinta.MainClass.ExceptionManager_UnhandledException (GLib.UnhandledExceptionArgs args) [0x00000] in <filename unknown>:0
  at GLib.ExceptionManager.RaiseUnhandledException (System.Exception e, Boolean is_terminal) [0x00000] in <filename unknown>:0

As you suspected, the issue is more with the gtk# itself. I don't know how to install gtk theme in Mac. Any help? I can then do some testing.

Cameron White (cameronwhite91) wrote :

Under Linux, my icon themes are installed under /usr/share/icons/, but I don't know if that's the same on a Mac.

Cameron White (cameronwhite91) wrote :

Could you try out https://github.com/downloads/PintaProject/Pinta/Pinta-1.2-alpha.app.zip ?

It's based off Pinta 1.2, with a couple fixes added for more robust icon handling from bug #879043

Robert Nordan (rpvn) wrote :

Since the new Mac test app seems to work, shall we change this to "fix committed"?

Changed in pinta:
milestone: none → 1.3
status: New → Fix Committed
Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers