Pinta does not run in Kubuntu

Bug #846396 reported by Robert Simmons on 2011-09-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
High
Unassigned
pinta (Ubuntu)
Undecided
Unassigned

Bug Description

I am using Kubuntu 11.04 with KDE 4.7.0. This is essentially a new install. When I installed pinta, it does not run. I tried to purge the package and reinstall, but the problem still exists. My guess is that there is a gnome dependency that Ubuntu provides no matter what, but since I'm running KDE, it is missing, and the package does not require it to be installed. If I run it in a terminal window I get the following error:

GLib.GException: Icon 'gtk-dialog-error' not present in theme
  at Gtk.IconTheme.LoadIcon (System.String icon_name, Int32 size, IconLookupFlags flags) [0x00000] in <filename unknown>:0
  at Pinta.ErrorDialog.Build () [0x00000] in <filename unknown>:0
  at Pinta.ErrorDialog..ctor (Gtk.Window parent) [0x00000] in <filename unknown>:0
  at Pinta.MainClass.ExceptionManager_UnhandledException (GLib.UnhandledExceptionArgs args) [0x00000] in <filename unknown>:0
  at GLib.ExceptionManager.RaiseUnhandledException (System.Exception e, Boolean is_terminal) [0x00000] in <filename unknown>:0
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose

Cameron White (cameronwhite91) wrote :

Could you try installing the gnome-icon-theme package? It worked for me (on Arch Linux, though) after installing that.

Let me know if that works.

Robert Simmons (rsimmons0) wrote :

Yes, that fixed the problem. So, there needs to be a dependency requirement added to this package so that gnome-icon-theme gets installed automatically with pinta.

Changed in pinta:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pinta - 1.0-3

---------------
pinta (1.0-3) unstable; urgency=low

  * [92d659c] Depend on gnome-icon-theme since Pinta will crash without the icons
    (LP: #846396)

 -- Iain Lane <email address hidden> Mon, 12 Sep 2011 22:39:00 +0100

Changed in pinta (Ubuntu):
status: New → Fix Released
Changed in pinta:
status: New → Fix Released
Sergio bh (kde-bhf) wrote :

Kubuntu 11.04
Pint 1.0-3
gnome-icon-theme dependency package doesn't fix problem.
To solve the problem you have to install gnome-icon-theme-full
Ciao.
Sergio

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers