crash on OS X Lion when opening file

Bug #836868 reported by David Nielsen on 2011-08-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
High
Unassigned

Bug Description

Pinta crashes consistently on OS X Lion when opening a file. I don't know how to capture a trace of this on OS X but take instructions well.

Tags: osx Edit Tag help
Cameron White (cameronwhite91) wrote :

Is Pinta crashing completely, or is it showing the "Unhandled Exception" dialog?

If it's showing the Unhandled Exception dialog, you can open the "Details" pane to get a trace, which you can then copy & paste here.

Otherwise, you'll probably have to launch Pinta from a terminal and paste the output from there.

It outright crashes without any unhandled exceptions dialog. I will update with proper terminal output once my apartment gets power and internet again should be within the week, maybe monday..

Ryan Peden (ryan04) wrote :

Ran into the same issue.

When trying to open a file, Pinta crashes immediately. I tried launching from the terminal and there was no output at all.

Cameron White (cameronwhite91) wrote :

I don't have a Mac, so I unfortunately can't investigate this directly.

Just to check, do you have the latest version of Mono/GTK# installed? (http://www.go-mono.com/mono-downloads/download.html)

Also, does this happen for every file, or are there certain files or file types that cause a crash?

Changed in pinta:
importance: Undecided → High
status: New → Confirmed
tags: added: osx

If a particular file is causing a crash, perhaps you should upload the file here so someone else can reproduce this bug.

Tom Fanning (i-il-8) wrote :

Opening the attached file crashes Pinta. Actually, opening any jpeg I have handy seems to crash it.

May be related - File -> Open doesn't seem to recognise jpeg or jpg files as image files, you have to select All Files in the list in the bottom right.

Also, getting the following on trying to start Pinta from the command line.

jeremy:Applications tf$ /Applications/Pinta.app/Contents/MacOS/pinta
/Applications/Pinta.app/Contents/MacOS:/Library/Frameworks/Mono.framework/Versions/Current/lib:/lib:/usr/lib

(Pinta:553): Gtk-WARNING **: Could not find the icon 'gtk-dialog-error'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
 http://icon-theme.freedesktop.org/releases
GLib.GException: Icon 'gtk-dialog-error' not present in theme
  at Gtk.IconTheme.LoadIcon (System.String icon_name, Int32 size, IconLookupFlags flags) [0x00000] in <filename unknown>:0
  at Pinta.ErrorDialog.Build () [0x00000] in <filename unknown>:0
  at Pinta.ErrorDialog..ctor (Gtk.Window parent) [0x00000] in <filename unknown>:0
  at Pinta.MainClass.ExceptionManager_UnhandledException (GLib.UnhandledExceptionArgs args) [0x00000] in <filename unknown>:0
  at GLib.ExceptionManager.RaiseUnhandledException (System.Exception e, Boolean is_terminal) [0x00000] in <filename unknown>:0
jeremy:Applications tf$

I just found Pinta, looks interesting, and sad to say my first experience with it has been very negative.

Cameron White (cameronwhite91) wrote :

Thanks for attaching the file!
It opens fine for me (with Pinta 1.0 on Windows) but I'll try on other platforms to see if I can reproduce the bug.

Also, the startup crashes you're getting are being tracked in issue #846660.

Jack Brandt (tp-jack) wrote :

Using Pinta 2 on an OSX Mac and it also crashes with every image I try to open. Sad, I am looking for something that is close to paint.net on Windows and this looked the closest. I did download the latest version of Mono as well, but no such luck... Does anyone have a fix for this? Is it a memory issue, or is it a bug. Please advise. Looking for another solution, at the moment.

grofaty (grofaty) wrote :

Jack, there is not "Pinta 2", can you please look at the Help | About window what is the version of Pinta you are using? And please write down how did you install Pinta? From tar file, build your own version from source code, something else? Can you upload the file to launchpad that crash Pinta on OSX, I can try opening the same file on Windows and Ubuntu (Linux distro), to see if the same problem appears.

I don't have a OSX, just trying to get more info for developers.

grofaty (grofaty) wrote :

Jack, discussed today on mailing list it looks like a problem in Mac

grofaty (grofaty) wrote :

...OSX Lion. If I understand correctly some problem in Mono for OSX Lion. Can you please confirm that you are also using OSX Lion? If so there is nothing really Pinta developers can do, just wait for Mono fix.

More info on mailing list discussion: https://groups.google.com/group/pinta/browse_thread/thread/dce0a7665fe58d9f?hl=en

Cameron White (cameronwhite91) wrote :

Can you still reproduce this issue with the Pinta 1.2 alpha build for Mac (https://github.com/downloads/PintaProject/Pinta/Pinta-1.2-alpha.app.zip) ?

I can open files just fine with the new build.

Changed in pinta:
status: Confirmed → Fix Committed
Changed in pinta:
milestone: none → 1.3
Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers