Pinta missing gtk-dialog-error icon on kubuntu 11.04

Bug #785034 reported by Daniel Andersson on 2011-05-19
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Pinta
Undecided
Unassigned

Bug Description

Binary package hint: pinta

Pinta requires the gtk-dialog-error icon and kubuntu 11.04 dont seem to have it by default (or as a package dependency)
Solvable by installing gnome-icon-theme

GLib.GException: Icon 'gtk-dialog-error' not present in theme
  at Gtk.IconTheme.LoadIcon (System.String icon_name, Int32 size, IconLookupFlags flags) [0x00000] in <filename unknown>:0
  at Pinta.ErrorDialog.Build () [0x00000] in <filename unknown>:0
  at Pinta.ErrorDialog..ctor (Gtk.Window parent) [0x00000] in <filename unknown>:0
  at Pinta.MainClass.ExceptionManager_UnhandledException (GLib.UnhandledExceptionArgs args) [0x00000] in <filename unknown>:0
  at GLib.ExceptionManager.RaiseUnhandledException (System.Exception e, Boolean is_terminal) [0x00000] in <filename unknown>:0

Thomas Capricelli (orzelf) wrote :

Same problem here, thanks for the workaround.

javexploit (fan-zero) wrote :

sudo apt-get install gnome-icon-theme

Changed in pinta (Ubuntu):
status: New → Confirmed
Masiosare (luis-zaldivar) wrote :

Pinta Version: 1.0-2build1

installing gnome-icon-theme doesn't work

gnome-icon-theme Version 3.1.4-0ubuntu1

Masiosare (luis-zaldivar) wrote :

Btw, only happens using a different gtk theme on kde. In my case, Oxygen-Molecule

Using oxygen-gtk works as expected, so this maybe is an Oxygen-Molecule problem.

Iain Lane (laney) wrote :

Please paste the traceback if installing gnome-icon-theme doesn't fix the problem.

javexploit (fan-zero) wrote :

sudo apt-get install gnome-icon-theme-full

Surak (smkozasa) wrote :

I installed Kubuntu AMD64 11.10 Oneiric from the Alternate CD, installed Pinta with aptitude (note that now both apt-get and aptitude will install gnome-icon-theme and humanity-icon-theme):

aptitude install pinta
The following NEW packages will be installed:
  cli-common{a} gnome-icon-theme{a} humanity-icon-theme{a} libgdiplus{a} libglib2.0-cil{a}
  libgtk2.0-cil{a} libmono-cairo4.0-cil{a} libmono-corlib4.0-cil{a}
  libmono-i18n-west4.0-cil{a} libmono-i18n4.0-cil{a} libmono-posix4.0-cil{a}
  libmono-security4.0-cil{a} libmono-sharpzip4.84-cil{a}
  libmono-system-configuration4.0-cil{a} libmono-system-core4.0-cil{a}
  libmono-system-drawing4.0-cil{a} libmono-system-security4.0-cil{a}
  libmono-system-xml4.0-cil{a} libmono-system4.0-cil{a} mono-4.0-gac{a} mono-gac{a}
  mono-runtime{a} pinta
0 packages upgraded, 23 newly installed, 0 to remove and 0 not upgraded.

BUT it still gives the error message as the original post. Yesterday of a sudden (computer was idle) gkrellm crashed with an error message, (something about calendar) and would not start anymore (only showed the same error message). I have uninstalled pinta (and its dependencies), there was obviously a relation, since gkrellm is gtk-based, then, after a reboot, gkrellm successfully started again. Now, I installed pinta again, and gkrellm is still up and running... who understands that?

Now I tried to install gnome-icon-theme-full as suggested by javexploit and pinta finally started. Gkrellm is still running. Will check if it resists a reboot... BTW please don't ask why a KDE user still uses gkrellm....

Cameron White (cameronwhite91) wrote :

From issue #879043 (https://bugs.launchpad.net/pinta/+bug/879043) and Surak's comment, it looks like "gnome-icon-theme-full" should be added as a dependency for Kubuntu 11.10.

didi_X8 (didi156-gmail) wrote :

Had the same issue (11.10 running KDE here). gnome-icon-theme installed and theme set to oxygen-gtk didn't work.
Installing gnome-icon-theme-full solved it.

Adolfo Jayme (fitojb) on 2012-04-29
affects: pinta (Ubuntu) → pinta
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers