Crashes on start w/ CLR20r3 error report (Win7)

Bug #781421 reported by Rob Raines on 2011-05-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
High
Robert Nordan

Bug Description

If I run the app as Administrator it runs fine.

If I run without admin rights I get the following error:

Description:
  Stopped working

Problem signature:
  Problem Event Name: CLR20r3
  Problem Signature 01: pinta.exe
  Problem Signature 02: 1.0.0.0
  Problem Signature 03: 4db88806
  Problem Signature 04: Mono.Posix
  Problem Signature 05: 2.0.0.0
  Problem Signature 06: 49679ae7
  Problem Signature 07: 541
  Problem Signature 08: 18
  Problem Signature 09: System.TypeInitialization
  OS Version: 6.1.7601.2.1.0.256.48
  Locale ID: 1033

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

Robert Nordan (rpvn) wrote :

Does anybody else have a 32-bit Windows 7 they can test with? I only have 64-bit and I'm unable to reproduce this issue.

Marek Marczak (retroman23) wrote :

I've got a 64bit Windows 7. There is the same problem. I can't install because of:

Podpis problemu:
  Nazwa zdarzenia problemu: CLR20r3
  Podpis problemu: 01: pinta.exe
  Podpis problemu: 02: 1.2.0.0
  Podpis problemu: 03: 4f91f515
  Podpis problemu: 04: gdk-sharp
  Podpis problemu: 05: 2.12.0.0
  Podpis problemu: 06: 4bae4553
  Podpis problemu: 07: 583
  Podpis problemu: 08: 4b
  Podpis problemu: 09: System.ArgumentException
  Wersja systemu operacyjnego: 6.1.7600.2.0.0.256.1
  Identyfikator ustawień regionalnych: 1045
  Dodatkowe informacje 1: 0a9e
  Dodatkowe informacje 2: 0a9e372d3b4ad19135b953a78882e789
  Dodatkowe informacje 3: 0a9e
  Dodatkowe informacje 4: 0a9e372d3b4ad19135b953a78882e789

Przeczytaj w trybie online nasze zasady zachowania poufności informacji:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0415

Jeśli zasady zachowania poufności informacji w trybie online nie są dostępne, przeczytaj nasze zasady zachowania poufności informacji w trybie offline:
  C:\Windows\system32\pl-PL\erofflps.txt

Rebooting after installing .net framework 4 and gtk# doesn't help.

Robert Nordan (rpvn) wrote :

Strange stuff. The error signature isn't exactly the same, so we can't be sure that it's the same root error but it might be. According to this page ( http://mrpfister.com/programming/demystifying-clr20r3-error-messages/ ) CLR20r3 is an error returned when an exception is triggered in release-mode code without being handled. We'll have to try disassembling stuff to find the underlying fault.

summary: - Crashes on start (Win7 x86)
+ Crashes on start w/ CLR20r3 error report (Win7)
Changed in pinta:
status: New → Confirmed
importance: Undecided → High
Robert Nordan (rpvn) wrote :

Marking it as confirmed since we have to independent reports even if I am unable to reproduce.

Robert Nordan (rpvn) wrote :

Marek, Rob (sorry about the lateness btw): Do you have Pinta installed in any special non-standard location? Did you perhaps install Pinta as a non-administrator user?

Technical details: I did some digging into the disassembly for gdk-sharp, and it seems the ArgumentException error originates in Gdk.PixBufLoader.InitFromAssemblyResource, which is called from Gdk.PixBuf.LoadFromResource, which we call from ResourceManager.GetIcon and DockItemContainer (). The error seems to occur when a System.IO.Stream is unable to read, so I'd say this has to do with filesystem permissions when trying to read icon files embedded in the Resource assembly. However, all the places we call to LoadFromResource are surrounded by try/catch blocks so I don't understand why this gets to crash the program. (!?)

Changed in pinta:
assignee: nobody → Robert Nordan (rpvn)
Robert Nordan (rpvn) wrote :

I now disassembled for the original bug report (Mono.Posix), and the error occurred in the native call Mono.Unix.UnixMarshal.AllocHeap, which allocates memory on Unix installtions. So I have no idea why that was called and failed on Windows, but again I suspect it has to do with permissions.

Cameron White (cameronwhite91) wrote :

The try/catch blocks around LoadFromResource in ResourceManager.GetIcon weren't added until after Pinta 1.2, so that might explain why the ArgumentException was able to crash Pinta.

Robert Nordan (rpvn) wrote :

Ah, great! I should have thought to check that... Well, based on that I think we can safely say that Marek's report is "fix committed".

The original bug report from 2011, however, is still a bit of a mystery. I searched for uses of heap allocation, and discovered that it's used in SystemManager to test for Mac OS. But that test is only called after a check for Windows has been done, and it's safely encased in a try/catch from long before Pinta 1.0 was released. We haven't heard more about users having this situation, so it might be a one-off local problem.

Robert Nordan (rpvn) on 2012-04-23
Changed in pinta:
status: Confirmed → In Progress
Marek Marczak (retroman23) wrote :

"Do you have Pinta installed in any special non-standard location? Did you perhaps install Pinta as a non-administrator user?"

No. I installed Pinta in default location (C://ProgramFiles(x86)/Pinta/) as administrator.

Marek Marczak (retroman23) wrote :

I also checked other versions of Pinta (1.1, 1.0, 0.6) and there is the same bug.

Robert Nordan (rpvn) wrote :

Marek, we believe your issue is fixed. try this development version: https://github.com/downloads/PintaProject/Pinta/pinta-1.3-preview-20120425.msi

Please report back how it goes. :-)

Marek Marczak (retroman23) wrote :

Robert, installation and launching was succeeded.
The application works fine. Thanks a lot! :)

grofaty (grofaty) on 2012-04-25
Changed in pinta:
status: In Progress → Fix Committed
Changed in pinta:
milestone: none → 1.3
Robert Nordan (rpvn) on 2012-05-01
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers