Backspace and delete using Text object does not work after pasting a print-screen

Bug #738065 reported by grofaty on 2011-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

Using Pinta 0.7 on Windows XP.
1. Print-screen and paste image with <CTRL>+<Alt>+V.
2. Click on Text object from Tools palette.
3. Click on canvas and start typing.
4. Press <Backspace> and whole image becomes black (primary color).
or press <Delete> and whole image becomes transparent.

grofaty (grofaty) wrote :

It looks like <Ctrl>+<Alt>+V after pasting it keeps image in selected mode.
Work-around:
1a) Click on Deselect All button from toolbar to deselect image.

This feature "of image staying selected" is not needed in "Paste into new Image" and it should be removed.

But on the other site it is very important to keep this feature if only "Paste" <Ctrl>+V is selected.

grofaty (grofaty) wrote :

Tested again in Pinta 1.1 on Windows XP sp3 and problem persists.

Cameron White (cameronwhite91) wrote :

Confirmed with Pinta 1.2 (daily build) on Ubuntu 11.10.

It looks like the <Backspace> and <Delete> keys are triggering the Fill Selection / Delete Selection actions instead of editing the text, since there is still an active selection.

Changed in pinta:
importance: Undecided → Medium
status: New → Confirmed
tags: added: easy-to-fix
grofaty (grofaty) wrote :

When fixing this bug be careful, because there are three kind of pastes:
1. Paste <Ctrl>+V (when pasting into existing image "Deselect All" action should NOT be done automatically, because if it is then it is no option to use "Move Selected Pixels" object)
2. Paste Into New Layer <Shift>+<Ctrl>+V (not a problem)
3. Paste Into New Image <Alt>+<Ctrl>+V (when pasting into new image there will be no action to move pixels because it can't really be moved to some other place because it already occupies 100% of canvas)

Cameron White (cameronwhite91) wrote :

Fixed: https://github.com/PintaProject/Pinta/commit/4c4e4be645549420c6f4c4b9914641cd825edc49

After using "Paste Into New Image", the selection is now automatically removed. The behaviour wasn't changed for any of the other paste actions.

Changed in pinta:
milestone: none → 1.2
status: Confirmed → Fix Committed
Robert Nordan (rpvn) on 2012-04-22
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers