Pinta crashes at startup - Error reading file '/home/[user]/.recently-used.xbel': Invalid argument.

Bug #732730 reported by grofaty on 2011-03-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

I installed Pinta 0.7 on Ubuntu 10.10 using:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install pinta

Pinta worked fine for a week or so, but today I have started Ubuntu and run command Pinta from ternimal and got the following error:

===========
(Pinta:2044): Gtk-WARNING **: Attempting to read the recently used resources file at `/home/[user]/.recently-used.xbel', but the parser failed: Error reading file '/home/[user]/.recently-used.xbel': Invalid argument.

Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
  at Pinta.Core.SettingsManager.GetSetting[Int32] (System.String key, Int32 defaultValue) [0x00000] in <filename unknown>:0
  at Pinta.MainWindow.CreateWindow () [0x00000] in <filename unknown>:0
  at Pinta.MainWindow..ctor () [0x00000] in <filename unknown>:0
  at Pinta.MainClass.Main (System.String[] args) [0x00000] in <filename unknown>:0
===========

Jonathan Pobst (jpobst) wrote :

That's just a warning, the actual crash is trying to read the settings.xml file.

Committed a fix in https://github.com/jpobst/Pinta/commit/5245c63cd4af1d0fc0f7a22163719a7305e7e5bc to just default settings if your settings file is somehow unreadable.

You can probably fix the issue by deleting your settings.xml file.

Changed in pinta:
importance: Undecided → Medium
milestone: none → 0.8
status: New → Fix Committed
grofaty (grofaty) wrote :

I was trying to delete settings file:
rm .config/Pinta/settings.xml
but I got the same error when started Pinta.

Now I did the following and solved the problem:
1. Uninstalled Pinta: sudo apt-get purge pinta
2. Removed all settings files: cd .config ; rm -rf Pinta/
3. Installed pinta again: sudo apt-get install pinta
4. I still got some "/home/[user]/.recently-used.xbel" warnings, but Pinta started.
5. I cleaned up system with: rm -rd .recently-used.xbel/ ; rm .recently-used
6. Started Pinta without any warning at all. Problem solved.

grofaty (grofaty) wrote :

I tested this problem in Pinta 1.1 and this problem does not appear anymore. It looks like some of the fix since 0.7 has solved the problem, so I am marking this bug report as fix released.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers