After pasting from clipboard in a image, pasted selection dissapear

Bug #724982 reported by Adolfo Jayme on 2011-02-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Cameron White

Bug Description

I work in a netbook with small screen, Ubuntu Natty.
If I open a screenshot file, open it at 100% (the image focus at center), then paste an small image on it (the pasted image takes place at top left corner, hidden at forst glance), and then drag it to the center with the move tool (to place it at the position I want) it "transparents" and literally I'm dragging an empty selection.

Adolfo Jayme (fitojb) wrote :
Adolfo Jayme (fitojb) on 2011-09-10
summary: - Image scrolling and image pasting are not friends
+ After pasting from clipboard in a image, pasted selection dissapear

I've noticed this bug as well. It seems to be triggered when part of the image is out of the visible view, and then moved. Pasting on to a new layer and then zooming out before moving seems to be a workaround.

Changed in pinta:
status: New → Confirmed
Changed in pinta:
importance: Undecided → Critical
importance: Critical → Medium
Robert Nordan (rpvn) wrote :

As far as I can see, an easy workaround is to drag the transparent square to wherever you want it, and then switch to a different tool like for example the hand tool. The image will then reappear where you dragged the selection to. This probably means it's fixed by the tools commit/deactivation routine, so looking at it might give some clues to how one can solve this bug. On the other hand, it could be something cairo-related where the off-screen pixels simply aren't available.

Loticat (j1787bienassis) wrote :

I have the same kind of problem, using it on ubuntu 11.10.

I've just started using it, and pinta would just be the be a GREAT software, easy to use and easy to learn, if it were not for this problem that simply makes it totally unuseable!! :-(
Everytime I paste and drag the selected item, part of it dissapears! Or else it is only part of it that gets dragged and the other part stays in place...
Thanks for trying to fix this! :-)

Cameron White (cameronwhite91) wrote :
Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
milestone: none → 1.4
status: Confirmed → Fix Committed
grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers