Transparency does not work

Bug #707587 reported by baltasarq on 2011-01-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

Pinta Version: 0.6

When you select a color (for example. white), and modify it to have 0 opacity, it correctly appears as transparent in the color tool chooser. However, if you use the paint bucket in order to fill, no pixels are changed to be transparent. The fill model or the tolerance options do not apparently affect the problem.

The checked pattern does not appear in the "transparent" pixels, and saving the image reveals that no pixels were actually affected.

grofaty (grofaty) wrote :

I can confirm behavior, but I think "transparent" is such an important "color" that should be put in the Palette as a "color" to select from.

Changed in pinta:
status: New → Confirmed
baltasarq (baltasarq) wrote :

Yep, that's interesting.
In Kolourpaint, they use a drawing of a pyramid in order to refer to the "transparent" color. Maybe something like that could be chosen.

Jonathan Pobst (jpobst) on 2011-02-16
Changed in pinta:
importance: Undecided → Medium
Jonathan Pobst (jpobst) wrote :
Changed in pinta:
milestone: none → 0.7
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

I have installed Pinta 0.7 on Windows XP and I can confirm problem is fixed.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers