Paintbrush size 1 doesn't work

Bug #702547 reported by Shrimp on 2011-01-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

1. Turn on Pixel Grid (View ---> Pixel Grid)
2. Zoom 3600%
3. Choose Paintbrush
4. Choose Brush width 1
5. Click on one of the boxes (nothing happens)

Shrimp (shrimpie) wrote :

Presumably, it should work like the pencil tool at that size.

grofaty (grofaty) wrote :

It looks like moving paintbrush over two boxes then it fills them both, interesting. What is also interesting is that color of paintbrush is gray, repainting the same same two boxes for 5-times it gets black. With pencil it gets black first time it is filed.

I have never really understand why are there two tools like Pencil and Paintbrush if both of them are doing the same thing (Paintbrush with width 1).

Shrimp (shrimpie) wrote :

The grey is due to anti-aliasing being on. Even if it is turned off, the tool doesn't work as it should. It doesn't draw until the mouse is moved over one box.

Jonathan Pobst (jpobst) wrote :
Changed in pinta:
importance: Undecided → Medium
milestone: none → 0.7
status: New → Fix Committed
grofaty (grofaty) wrote :

I have installed Pinta 0.7 on Windows XP and I can confirm problem is fixed.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers