Copy and paste does not work for Text object

Bug #696417 reported by grofaty on 2011-01-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Olivier Dufour

Bug Description

In Pinta 0.5 on Windows XP sp3 / Ubuntu 10.10 I have tried the following:

Test 1: Pasting
1. Open text editor type in some text and copy the text.
2. In Pinta click on Text object and click on canvas to start typing.
3. Press <CTRL>+C or Edit | Paste or Paste button on toolbar and text is not pasted

Test 2: Selecting text
1. In Pinta select Text object and click on canvas.
2. Press <Shift>+<Right> or <Shift>+<Left> or <Shift>+<Home> or <Shift>+<End> and no text is selected.

Test 3: Copying
1. Test 2 showed that no text can be selected so copy can't be used.
2. Pressing <CTRL>+C, it looks this is not working, because if creating new text object on object <CTRL>+P is not pasting.

It would be nice if copy/paste would work in Text object.

grofaty (grofaty) wrote :

Tested in Pinta 0.6 on Windows XP sp3. Problem remains!

Jonathan Pobst (jpobst) on 2011-02-19
Changed in pinta:
status: New → Confirmed
importance: Undecided → Low
Olivier Dufour (olivier-duff) wrote :

I work on this feature to get back to code on pinta.
I take this one because I see new design and it is not a priority so other people won t take this task.
Anyway, Pasting work on my branch but need some work for copy to show selected text in video invert.

grofaty (grofaty) wrote :

dufoli, I have been chatting with Jonathan and most probably all the request marked as Low are probably not going to be solved any time soon. Can you please in head of this bug report select "Assigned to" and select "Assign me", that others can know you are trying to solve the problem.

Olivier Dufour (olivier-duff) wrote :

this is working inmy master branch on github.

Changed in pinta:
assignee: nobody → dufoli (olivier-duff)
Olivier Dufour (olivier-duff) wrote :

the code is here :
https://github.com/dufoli/Pinta/tree/texttool

It need to be update to last branch and check if bug remain in it.

IIRC, the code is very complicated because it mean support selection/multi-line selection/multiline delete/...

Because I have to calculate what is position of selection start and selection end.

I will take a look to try to simplify all this code before merge.

grofaty (grofaty) wrote :

Oliver, I tried to compile the code on Ubuntu 11.10 and I am getting A LOT of errors, see bellow.

========
/usr/lib/mono/4.0/Microsoft.CSharp.targets: error : Error executing tool '/usr/bin/gmcs': ApplicationName='/usr/bin/gmcs', CommandLine='/noconfig @/tmp/tmp79fbb441.tmp', CurrentDirectory='/home/[MYUSER]/Downloads/textPinta/System.ComponentModel.Composition'
   Task "Csc" execution -- FAILED
   Done building target "CoreCompile" in project "/home/[MYUSER]/Downloads/textPinta/System.ComponentModel.Composition/System.ComponentModel.Composition.csproj".-- FAILED
  Done building project "/home/[MYUSER]/Downloads/textPinta/System.ComponentModel.Composition/System.ComponentModel.Composition.csproj".-- FAILED
 Task "MSBuild" execution -- FAILED
 Done building target "Build" in project "/home/[MYUSER]/Downloads/textPinta/Pinta.sln".-- FAILED
Done building project "/home/[MYUSER]/Downloads/textPinta/Pinta.sln".-- FAILED

Build FAILED.
Errors:

/home/[MYUSER]/Downloads/textPinta/Pinta.sln (default targets) ->
(Build target) ->
/home/[MYUSER]/Downloads/textPinta/Pinta.Resources/Pinta.Resources.csproj (default targets) ->
/usr/lib/mono/4.0/Microsoft.CSharp.targets (CoreCompile target) ->

 /usr/lib/mono/4.0/Microsoft.CSharp.targets: error : Error executing tool '/usr/bin/gmcs': ApplicationName='/usr/bin/gmcs', CommandLine='/noconfig @/tmp/tmp2d5717f1.tmp', CurrentDirectory='/home/[MYUSER]/Downloads/textPinta/Pinta.Resources'

/home/[MYUSER]/Downloads/textPinta/Pinta.sln (default targets) ->
(Build target) ->
/home/[MYUSER]/Downloads/textPinta/System.ComponentModel.Composition/System.ComponentModel.Composition.csproj (default targets) ->
/usr/lib/mono/4.0/Microsoft.CSharp.targets (CoreCompile target) ->

 /usr/lib/mono/4.0/Microsoft.CSharp.targets: error : Error executing tool '/usr/bin/gmcs': ApplicationName='/usr/bin/gmcs', CommandLine='/noconfig @/tmp/tmp79fbb441.tmp', CurrentDirectory='/home/[MYUSER]/Downloads/textPinta/System.ComponentModel.Composition'
========

grofaty (grofaty) wrote :

Just wondering was this bug fixed? Was Oliver's code properly tested and merged into official development branch?
Tested on Pinta 1.2 on Windows and latest development on Ubuntu 11.10 and problem persists.

Cameron White (cameronwhite91) wrote :

No, we never merged it in for Pinta 1.2

Adolfo Jayme (fitojb) on 2012-04-29
tags: added: text-tool
Olivier Dufour (olivier-duff) wrote :

pull request sent.
The code is fixed and work perfectly with my tests.

grofaty (grofaty) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
Changed in pinta:
milestone: none → 1.4
grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers