Pinta crashes when changing the values in oil painting

Bug #696410 reported by Sam Neil on 2011-01-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
High
Unassigned

Bug Description

Select a photo and choose the effect Oil painting. Increase the coarseness and then decrease the value and the application crashes.

grofaty (grofaty) wrote :

I have tested above instructions on Pinta 0.5 on Windows XP and Ubuntu 10.10 and can't reproduce the problem.

Sam, can you please write more about your system:
1. What is your operating system and version?
2. What is your Pinta version (from Help | About menu)?

Can you please start Pinta from terminal/command prompt and reproduce the problem, then paste error text output to this bug report.

Hi;

1. Windows XP Pro SP-3
2. Pinta 0.5

Starting from C. prompt is the same. If you increase the coarseness and then
change it to something to below 10 or 15, it crashes. I see if I can capture
a video of it.

Sam.

On 2 January 2011 08:04, grofaty <email address hidden> wrote:

> I have tested above instructions on Pinta 0.5 on Windows XP and Ubuntu
> 10.10 and can't reproduce the problem.
>
> Sam, can you please write more about your system:
> 1. What is your operating system and version?
> 2. What is your Pinta version (from Help | About menu)?
>
> Can you please start Pinta from terminal/command prompt and reproduce
> the problem, then paste error text output to this bug report.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/696410
>
> Title:
> Pinta crashes when changing the values in oil painting
>
> Status in Pinta:
> New
>
> Bug description:
> Select a photo and choose the effect Oil painting. Increase the coarseness
> and then decrease the value and the application crashes.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/pinta/+bug/696410/+subscribe
>

--
Regards
Sam Neil

grofaty (grofaty) wrote :

Sam, can you please post the error message, because we are using the same system and I can't reproduce the problem. Error message would help much.

Sam Neil (sneil69) wrote :
  • pinta.swf1 Edit (598.2 KiB, application/octet-stream; name="pinta.swf1")

Sorry there is no error message as the app crashes without any. Please see
attached video... Please rename to .swf

On 3 January 2011 06:51, grofaty <email address hidden> wrote:

> Sam, can you please post the error message, because we are using the
> same system and I can't reproduce the problem. Error message would help
> much.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/696410
>
> Title:
> Pinta crashes when changing the values in oil painting
>
> Status in Pinta:
> New
>
> Bug description:
> Select a photo and choose the effect Oil painting. Increase the coarseness
> and then decrease the value and the application crashes.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/pinta/+bug/696410/+subscribe
>

--
Regards
Sam Neil

grofaty (grofaty) wrote :

First of all I didn't know that Flash movies can directly be opened by browser like: File | Open. Nice. I have watch your video and now I can reproduce problem.

1. Paste some picture to Pinta 0.5 on Windows XP sp3
2. Effects | Artistics | Oil Painting
3. Just decrease Coarsenes settings by one (or any other number).

I have tried several things increasing and decreasing Coarsenes settings and if I understand correctly Pinta always crashes when settings gets bellow 50 Pinta.

No error is returned. I have also tried to execute from cmd and there is also no error.

---
I have also tried to reproduce the problem in Pinta 0.5 on Ubuntu 10.10 and Pinta. On Ubuntu Pinta does not crashes if getting bellow 50, but it does crashes if it gets to 0, then the error is returned (in terminal):
========
Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
  at Pinta.Effects.OilPaintingEffect.RenderEffect (Cairo.ImageSurface src, Cairo.ImageSurface dest, Gdk.Rectangle[] rois) [0x00000] in <filename unknown>:0
========

Changed in pinta:
status: New → Confirmed
Jonathan Pobst (jpobst) wrote :
Changed in pinta:
importance: Undecided → High
milestone: none → 0.6
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

I have tested on Pinta 0.6 on Windows XP sp3. Problem solved.

Changed in pinta:
status: Fix Committed → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments