Change to fit-to-window zoom doesn't work if current zoom is smaller

Bug #694074 reported by Khairuddin Ni'am on 2010-12-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Low
Unassigned

Bug Description

1. Open an image.
2. Select zoom scale that is smaller than fit-to-window zoom
3. Try change zoom level to fit-to-window zoom

Image won't scale up to fit-to-window zoom scale and zoom text changed to 100%.

It only work if current zoom level is larger enough than fit-to-window zoom.

Jonathan Pobst (jpobst) wrote :

I think the main point is to give you the maximum zoom when your image is too big for the window. I don't know if it matters when your image is small enough to fit in the window.

Paint.Net zooms to 100%
GIMP and Photoshop zoom to greater than 100%.

I don't really have a preference.

Khairuddin Ni'am (niam-nfinity) wrote :

Maybe I didn't explain it properly.

What i mean is the odd behavior of "window" zoom, not the behavior after Pinta create or open an image.

1. Let say I create a new image that is larger than pinta's window. For example I create a new image with size 3000 x 3000

2. After I click OK, Pinta will scaled down the canvas to fit the window because the actual size larger than the window itself. On my computer, the image scaled down to 19%. So, my current zoom scale is 19%.

3. If I select "window" from zoom drop down menu, I expect my image will be scaled to fit the window. Because my current zoom scale is already fit to window, I expect it won't change anything if I select "window" zoom.
What actually happens is my image is scaled up to it's original size, 100%. On this case, "window" zoom's behavior is odd.

4. After step 3, my current zoom scale is 100%. Now, if I select "window" zoom again, Pinta will scaled down my image to fit the window, that is 19%. On this case, "window" zoom is acting properly.

Note : I prefer Paint.Net behavior than GIMP or Photoshop when open or create an image. Show it's original size if it smaller than window, otherwise scaled down to fit the window.

grofaty (grofaty) wrote :

Strange... I have tested the above steps on Pinta0.5 on Windows XP.
1. I created new 3000 x 3000 image
2. Pinta scaled down to 20% in my case
3. I selected "Window" from drop down menu and NOTHING happens.
I have selected several zoom-drop-down options and then after that selected "Window" zoom option from drop-down window. "Window" option does not get any effect in my case. It just looks like having no action is executed for Window.

So I can't confirm exact behavior like yours, but I can confirm that "Window" options is probably broken.

Jonathan Pobst (jpobst) wrote :
Changed in pinta:
importance: Undecided → Low
milestone: none → 0.6
status: New → Fix Committed
grofaty (grofaty) wrote :

Strange... I have tried to reproduce comment #3 but now Pinta 0.7 behaves like this:
Note: On Windows I use 1024x768 screen resolution.
1. I created new 3000 x 3000 pixel image
2. Pinta scaled down to 20%
3. Zoom to 3600%
4. Back to Zoom = Window and Pinta zooms to 19%
5. Select one more time Zoom = Window and Pinta zooms to 20%.

Interesting that sometimes it selects 19% and sometimes 20%.

Changed in pinta:
status: Fix Committed → New
status: New → Fix Released
grofaty (grofaty) wrote :

Ah... I have selected "Fix Released" by mistake. I should select "New", but now I can set it to new anymore. Can you please change the status back to new.

Jonathan Pobst (jpobst) wrote :

What are saying is still broken on this? That it sometimes picks 19% and sometimes picks 20%?

My guess is that is caused by whether there are scrollbars visible or not, as the affects the window size.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers