Three dots in Translation missing but incorrectly displayed in menus for Slovenian language

Bug #683242 reported by grofaty on 2010-11-30
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Adolfo Jayme

Bug Description

According to Slovenian language spelling rules there should always be three dots separated after the string. So in English
"Levels..." in Slovenian "Ravni ..." Did you notice the single space after the word Ravni and then following with three dots. There is no space between word and three dots in English, but according to Slovenian spelling rules it must be in Slovenian translation.

A lot of strings like "New...", "Open..." etc have in Translation (Rosetta) three dots after word which is OK, but there are some strings like:

49. Layer Properties
98. Posterize
100. Levels
103. Hue / Saturation
104. Brightness / Contrast
106. Curves

that do not have tree dots in Translation, but three dots appear in menus, but in Slovenian translations this is wrong, missing space.

There are also all of 29 options from Filters menu, that are automatically having three dots after word. Which are also incorrect in Slovenian language.

Can you please add three dots to Translation instead of using them automatically in program.

Thanks

Jonathan Pobst (jpobst) wrote :

How about adding just the ellipsis to the translations? So you could replace "..." with " ..." if your language does it that way.

grofaty (grofaty) wrote :

That is exactly what I was thinking, probably I was not clear enough.

Jonathan Pobst (jpobst) wrote :
Changed in pinta:
importance: Undecided → Low
milestone: none → 0.6
status: New → Fix Committed
grofaty (grofaty) wrote :

It looks partially fixed. Layers | Layer Properties fixed, but menus Adjustments and Filters still don't have a space before "..."

Changed in pinta:
status: Fix Committed → New
Jonathan Pobst (jpobst) wrote :

Can you double-check the translation? It looks like the "..." item isn't changed to "<space>...".

https://github.com/jpobst/Pinta/blob/release-0.6/po/messages-sl.po#L1202

grofaty (grofaty) wrote :

Oh, it looks like some kind of bug in Launchpad Rosetta. When ever I add a space before a string it is not accepted. It is also possible that this is feature of Launcpad, you know like trimming a string.

Jonathan Pobst (jpobst) on 2011-02-21
Changed in pinta:
milestone: 0.6 → none
Cameron White (cameronwhite91) wrote :

Looks like this was fixed a little while ago, and this bug never got updated

https://github.com/PintaProject/Pinta/commit/b5b22d854e534fc71e26971313dc5d797e2191f9

Changed in pinta:
milestone: none → 1.2
status: New → Fix Committed
Robert Nordan (rpvn) on 2012-04-22
Changed in pinta:
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2012-09-06
Changed in pinta:
assignee: nobody → Adolfo Jayme Barrientos (fitoschido)
grofaty (grofaty) wrote :

Similar debate with examples in bug 1424336.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers