Pinta fails to open TIFF files with .tif extension

Bug #676099 reported by carlton whitehead on 2010-11-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

When opening a valid TIFF file with a .tif extension, either by the File -> Open dialog within Pinta, or by the right-click -> Open With -> Pinta dialog box on Ubuntu 10.10, Pinta displays an error message: "Could not open file: /path/to/file.tif". In my view, this is a low priority issue, as it can be worked around merely by changing the file's extension to .tiff. However, if Pinta is going to associate itself to handle .tif files, it ought to be able to open them properly.

carlton whitehead (cebesius86) wrote :

This happened using Pinta 0.5 on Ubuntu 10.10 AMD64 desktop. I haven't tested other versions or platforms.

grofaty (grofaty) wrote :

It looks like a minor problem, but I think it should be solved with some priority (probably not hard to fix), because non-geek users aren't so educated to rename file extension - they probably think that tif format is not supported.

It would also be nice that message: "Could not open file: /path/to/file.tif" should be changed if possible and write more info what is the real reason that file can't be opened. Is there unsupported format? Is it file permissions? Something else?

Changed in pinta:
status: New → Confirmed
Mathias Fussenegger (f-mathias) wrote :

Added a quick patch to fix the issue.

Regarding a more descriptive error message: In this case this would've been misleading, as it would've told you that the file type isn't supported, although it actually is. It just couldn't recognise the extension.

Jonathan Pobst (jpobst) wrote :
Changed in pinta:
importance: Undecided → Medium
milestone: none → 0.6
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

I have checked Pinta 0.6 on Ubuntu 10.10 and files with tif extension can be opened. Problem solved.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers