Text tool won't work after undone from history panel

Bug #672394 reported by Shrimp on 2010-11-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

1. Type text
2. Manually undo the text by clicking on "New Image" from the History panel
3. Text will no longer work

grofaty (grofaty) wrote :

I can also produce the problem (Pinta 0.5 on Ubuntu 10.10).

The only way to get text work again it to quit Pinta and start it again.

But it is interesting if Undo is used from toolbar then Text object works fine. The only strange behaviour appears if History window is used to undo.

Changed in pinta:
status: New → Confirmed
Jonathan Pobst (jpobst) on 2010-12-14
Changed in pinta:
importance: Undecided → Medium
Jonathan Pobst (jpobst) wrote :

Fixed in https://github.com/jpobst/Pinta/commit/133233fcf3aca0a947d849e6f6f9b05104563bf6.

The issue is that the History panel takes the focus, so the text tool never receives any key presses. Clicking back in the canvas to place your cursor will now grab the focus back, so you can type again.

Thanks for the report!

Changed in pinta:
milestone: none → 0.6
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

I have tested on Pinta 0.6 on Windows XP sp3. Problem solved.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers