After erasing some portion of picture and refilling it with bucket eraser border is preserved

Bug #671508 reported by grofaty on 2010-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

In Pinta 0.5 on Ubuntu 10.1o I have drawn a rectangle with Rectangle object. Then I have erased one side (border) of rectangle. I would like to fill this erased space with white color. So I have clicked on arrow to switch black and white colors, clicked on Paint Backed object and then clicked on picture on the place where border was deleted with Eraser.

I have expected that all of the "erased" space will become white, but now I see there is some border that is not whitened. I think it should be whitened.

See attached pictures.

grofaty (grofaty) wrote :
grofaty (grofaty) wrote :

And a picture after bucket is filled the white color on "erased" space.

Jonathan Pobst (jpobst) wrote :

This is caused by antialiasing, which is the default. You can turn it off in the tool toolbar.

However, the eraser tool was not respecting the antialias setting, so it still won't work. :/

Fixed in https://github.com/jpobst/Pinta/commit/06ebf2f26d80c8e702270b8fdd0c714b5316ef7e.

Changed in pinta:
importance: Undecided → Medium
milestone: none → 0.6
status: New → Fix Committed
grofaty (grofaty) wrote :

In Pinta 0.6 problem now can be solved using right mouse button.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers