When clicked on canvas text is copied from doc1 to doc2 - why?

Bug #671495 reported by grofaty on 2010-11-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

In Pinta 0.5 on Ubuntu 10.10 I have done the following:
1. Start Pinta (if already started close it).
2. "Unsaved Image 1" is displayed in title bar. Click on Text object from Tools.
3. Click on canvas and type like "aaa".
4. Click on New button from toolbar (accept default 800x600) to get "Unsaved Image 2" document.
5. Now just click on canvas and text "aaa" from "Unsaved Image 1" will also appear on "Unsaved Image 2".

You can click on Windows menu and switch between "Unsaved Image 1" and "Unsaved Image 2" and you will see "aaa" text on both of them.

I think step 5 should not produce a copy text from "Unsaved Image 1" or am I missing something?

grofaty (grofaty) on 2010-11-05
description: updated
Jonathan Pobst (jpobst) on 2010-12-14
Changed in pinta:
importance: Undecided → Medium
Jonathan Pobst (jpobst) wrote :
Changed in pinta:
milestone: none → 0.6
status: New → Fix Committed
Shrimp (shrimpie) wrote :

This is still happening to me. What's strange is that when I first used 0.6, it seemed to be fixed but subsequent usage of Pinta, this bug has returned and never left. Well, all I remember is I kept clicking on the second new document and the text from from the first document would eventually appear. It wouldn't show on the first click though.

Shrimp (shrimpie) wrote :

Oh and apparently trying to close all the windows afterwards using Close All -----> Close without saving button freezes/crashes Pinta. All other uses of the Close All seem fine.

Jonathan Pobst (jpobst) wrote :

Yeah, looks like this is still an issue, reopening.

Changed in pinta:
milestone: 0.6 → none
status: Fix Committed → New
grofaty (grofaty) wrote :

I can confirm it is still an issue on Pinta 0.6 on Windows XP sp3.

Changed in pinta:
status: New → Confirmed
Jonathan Pobst (jpobst) wrote :
Changed in pinta:
milestone: none → 0.7
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

I have installed Pinta 0.7 on Windows XP and I can confirm problem is fixed.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers