After adding a new layer, adjusting the transparency will cause a crash.

Bug #670767 reported by Uber Dudditz on 2010-11-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
High
Unassigned

Bug Description

When creating a new layer and trying to change the transparency level of the layer, it pops up a error message with no content, just a plank window. After clicking the close button, the program immediately crashes.

grofaty (grofaty) wrote :

Can you please write step by step instructions, because I can't reproduce the problem. Can you please also write which version of Pinta are you using and operating system name and version. If you build code from yourself write this done, if you installed from PPA write which PPA have you installed from. Can you also start pinta from terminal and then when crash is produced, to post all the errors that are displayed in terminal.

Uber Dudditz (uber-dudditz) wrote :

Sorry for the wait. But upon further inspection, I've realised that it might not be adjusting the transparency that did it. I went to what seems to be the root of the issue, and found:
Open pinta, create new layer. Make a selection (I used the box selection tool) in that new layer, then move the pixels. After this, once I tried to make the layer non-visible, it brought up the blank error box and crashed. This was the terminal output:
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose

I am using Pinta 0.5, and I upgraded from ppa:moonlight-team/pinta. I am using Ubuntu 10.10.

Uber Dudditz (uber-dudditz) wrote :

My apologies again, but It seem that making a new layer isn't even needed. :/
Simply make the selection, and after moving the pixels and trying to make the layer invisible, it will crash.

Jonathan Pobst (jpobst) wrote :

Awesome, I can reproduce that. Thanks for the follow up!

grofaty (grofaty) on 2010-11-23
Changed in pinta:
status: New → Confirmed
Jonathan Pobst (jpobst) wrote :
Changed in pinta:
importance: Undecided → High
milestone: none → 0.6
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

I have tested on Pinta 0.6 on Windows XP sp3. Problem solved.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers