Shortcuts do not work

Bug #633104 reported by Dmitry Petrov on 2010-09-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Low
Unassigned

Bug Description

I've installed Pinta 0.4 from moonlight team ppa.
Though app works I can't change tools with shortcuts, e.g. I can't select Hand tool with H key

System: Ubuntu 10.04 with all updates

I'm finding this too.
Ubuntu: 10.10
Pinta: 0.5

Igor2x (igor2x) wrote :

I can't reproduce this problem. It works fine on my system: Pinta 0.5 on Ubuntu 10.10.

Does this problem appear every time you use shortcuts. Have you set some system wide shortcuts or using some additional system wide program for shortcuts?

Dmitry Petrov (demon-krasno) wrote :

Yes, this problem is reproduced every time. I use only one additional program that captures the hotkeys - deadbeef, but pinta doesn't handle shortcuts even when this program is turned off.

In addition to default gnome hotkeys I've assigned CA-{1,2,3,q,w,e,a,s,d} to switch between desktops.
Also, there are two languages in my system - English and russian, but pinta behavior doesn't depend on the input language.

Can I debug this on my system somehow?

Jonathan Pobst (jpobst) on 2010-12-14
Changed in pinta:
importance: Undecided → Low

I haven't set any system hotkeys except those that ship with Ubuntu.

They still do not work 0.6 either.

schmendrick (felix-schmutz) wrote :

i just tried with the new Ubuntu 11.04 (natty) -32bit using Gnome 2.32.1 and Pinta 0.6.0.0 (installed via the repos).

the shortcuts work just fine for me

schmendrick (felix-schmutz) wrote :

okay, the good news is, NOW i can reproduce and looked into the debugger:

i have the same problem with my other ubuntu installation currently on Ubuntu 10.04 LTS ( Lucid Lynx)

i am using the latest git sources.

i tracked the problem down: it is due to the fact that Gdk.KeyEvent.State in
 PintaCanvas.cs=>PintaCanvas_KeyPressEvent

is having a value of Mod2Mask instead of the expected none.

When digging through the GTK documentation on
http://docs.go-mono.com/index.aspx
i found that this represents:
Mod2Mask=>The fifth modifier key (it depends on the modifier mapping of the X server which key is interpreted as this modifier).

which means GTK thinks that this modifier key is pressed (which it is not).

i have ABSOLUTELY NO CLUE why this is/can be the case (but i am not proficient in GTK).
but i guess this is not a bug of pinta, but a bug in the underlying library!

we/i can implement a WORKAROUND by just ignoring if one of those special mask modifiers is reported.

but maybe somebody with GTK experience has an idea how this can be better solved or who we we can report this to?

Cameron White (cameronwhite91) wrote :

This sounds very similar to the problem in issue #852770 (fixed in https://github.com/PintaProject/Pinta/commit/78c1fa96d378b2bcfb75eaab506772433e237a2c).

When keys like Caps Lock or Num Lock are enabled, they show up as modifier keys that are pressed down.

On my machine, enabling Caps Lock or Num Lock allowed me to finally reproduce this issue.

Changed in pinta:
status: New → Confirmed
Cameron White (cameronwhite91) wrote :
Changed in pinta:
milestone: none → 1.2
status: Confirmed → Fix Committed
Robert Nordan (rpvn) on 2012-04-22
Changed in pinta:
status: Fix Committed → Fix Released
Dwayne (gigolocrib) wrote :

Uhm. This is still extant. Program starts, the keys always work. But a little way in, usually after dragging the palette box about, they all just stop. One time I observed the buttons entering a field of text such as a "find" box, but most often this does not come visible though I suspect it is a key part of the whole business. [I could detect no apparent purpose for a find dialog box in this program.] - Pinta 1.3 from Trusty repo

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers