Text tool: rendered on a white background while typing

Bug #592357 reported by Maia Everett on 2010-06-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Low
Unassigned

Bug Description

If text is being typed on a non-white background, a white rectangle is visible under it. It disappears when pressing Enter.
I think the tool surface should be cleared with a transparent rectangle (with alpha 0), not a white one.

Jonathan Pobst (jpobst) on 2010-06-15
Changed in pinta:
importance: Undecided → Low
status: New → Confirmed
Olivier Dufour (olivier-duff) wrote :

this tool is copy from PDN. I am not sure if is a good behaviour or not.
Because blank area provide a better contrast but if you want to write text in blank, you will see nothing.

Yalçın Can (yalcin.can) wrote :

I think transparency would be good for real-time image editing because when you choose the wrong color sometimes text becomes hard to see.

Jonathan Pobst (jpobst) wrote :

Fixed in https://github.com/jpobst/Pinta/commit/133233fcf3aca0a947d849e6f6f9b05104563bf6.

We now draw directly on top of the existing image, so the text will look exactly the same as when it is finished.

Thanks for the report!

Changed in pinta:
milestone: none → 0.6
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

I have installed Pinta 0.7 on Windows XP sp3 and problem is fixed.

Changed in pinta:
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2012-04-29
tags: added: text-tool
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers