Shape tools are very slow

Bug #582106 reported by Jonathan Pobst on 2010-05-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Low
Unassigned

Bug Description

The shape tools (rectangle, ellipse, etc.) are very slow, especially compared to the selection tools, which use alpha blending.

Jonathan Pobst (jpobst) wrote :

Assigning this to me, as I have a lot of shapes work I am doing, but it will take some time.

Changed in pinta:
assignee: nobody → Jonathan Pobst (jpobst)
Jonathan Pobst (jpobst) on 2011-02-19
Changed in pinta:
assignee: Jonathan Pobst (jpobst) → nobody
importance: Medium → Low
Ari (ari-lp) wrote :

Shape and selection tools are both very slow for me (Ubuntu 12.04 LTS).

grofaty (grofaty) wrote :

What is your Pinta version? I have tested this on Pinta latest development on Ubuntu 12.04 LTS and I have no issue at all. I have been using Pinta/Ubuntu for years and I have never seen this kind of problem.

Don't know maybe some specific problem to your configuration (graphic drivers etc)...

The only think I can imagine is if working with very large images like 2000 x 2000 and then I notice some performance drop in selection tool, like a second delay, but this is reasonable because of using old notebook running inside virtual machine.

Can you please specify what is your image size and what does "very slow" mean, is this taking some seconds, how many seconds it takes... Is it slow when drawing (like displaying step-by-step rectangle) or slow only with drawing.

Ari (ari-lp) wrote :

I added a screencast showcasing the slowdowns I am dealing with. In this case I was working with a pretty small image (only measuring about 1000x1000px), which I attached as well. CPU load on using the selection tools quickly spiked to ~20% for Pinta. You can see this in the end of the video.

Some additional information on my configuration:

~$ apt-cache policy pinta
pinta:
  Installed: 1.4-0ppa2~precise
  Candidate: 1.4-0ppa2~precise
  Version table:
 *** 1.4-0ppa2~precise 0
        500 http://ppa.launchpad.net/pinta-maintainers/pinta-stable/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     1.1-1 0
        500 http://ftp-stud.hs-esslingen.de/ubuntu/ precise/universe amd64 Packages

##Note: This bug appeared both with the latest PPA release and the one provided in the official repositories##

$ uname -a
Linux AcerUBN 3.2.0-36-generic #57-Ubuntu SMP Tue Jan 8 21:44:52 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

System specs:

- Core i5 @ 2,66 Ghz
- AMD HD 5650 with FGRLX (Catalyst 12.6)
- 4 GB RAM

Desktop environment:

- LXDE/Openbox

##Note: toggling composition on/off made no difference##

P.S.: Sorry for the delay!

Ari (ari-lp) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers