Rectangle border is always cut off

Bug #1922470 reported by Nico
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

This issue happens with 1.7 and the latest master:

1. Open an image
2. Select red color
3. Click the rectangle tool
4. Select fill style outline
5. Increase brush width to 5
6. Create a rectangle (for example to highlight a screenshot section)
7. Choose the Select tool
8. Click anywhere in the image to finish the changes
9. Zoom in and you will see, that the border has weird edges most of the time

See Screenshot, this time the upper left corner.

It turns out, that the broken corner is always the one you began the drawing.

Revision history for this message
Nico (nicohood) wrote :
Revision history for this message
Nico (nicohood) wrote :

It turns out, that the broken corner is always the one you began the drawing.

description: updated
Changed in pinta:
importance: Undecided → Medium
milestone: none → 1.8
status: New → Confirmed
tags: added: line-tool
Revision history for this message
Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
Changed in pinta:
milestone: 1.8 → 1.7.1
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers