Inconsistent SaveAs window with other Gnome programs like Gedit

Bug #1909664 reported by grofaty
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Fix Released
Low
Unassigned

Bug Description

Pinta 1.8 development on Ubuntu 20.04:
https://github.com/PintaProject/Pinta/actions/runs/451486225

I have checked the "Save As" dialog between Gedit and Pinta and I see Gedit has two nice features:
a) Current unsaved entered into Name field
b) Save button enabled and marked with green color, so it is obvious button is enabled.

See attachment for details.

Revision history for this message
grofaty (grofaty) wrote :
Changed in pinta:
importance: Undecided → Low
milestone: none → 1.8
status: New → Confirmed
tags: added: easy-to-fix
Revision history for this message
Dark Dragon (darkdragon-001) wrote :

The green save button is fixed in the latest build.
This could be because of https://bugs.launchpad.net/pinta/+bug/1909807 ?

Revision history for this message
Cameron White (cameronwhite91) wrote :

I think the remaining issue is just that the filename field isn't pre-populated with something (e.g. "Unsaved Image 1") when saving a new image, which also means that the Save button is disabled at the beginning.

The save button does appear green after entering in a filename, since the native file dialog is now being used.

Revision history for this message
Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
Revision history for this message
grofaty (grofaty) wrote :

I tested the latest development on Ubuntu 20.04 from https://github.com/PintaProject/Pinta/actions/runs/1274436564 and I don't see this as fixed. In Save As dialog Name field is still empty when new image is saved. According to your #3 post above I expect somethign like "Unsaved Image 1".

Revision history for this message
Cameron White (cameronwhite91) wrote :

Thanks for testing - the change did work on macOS, but testing on Ubuntu 20.04 it's still not working...

Changed in pinta:
status: Fix Committed → Confirmed
Revision history for this message
Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
Revision history for this message
grofaty (grofaty) wrote :

Fixed. Thanks. Tested on latest 1.8-development from github on Ubuntu 20.04.

Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers