Rotate Layer does not work properly

Bug #1905176 reported by Nico
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Undecided
Unassigned

Bug Description

1. Open Pinta with an empty image
2. Rotate Layer 40 Degree
3. Try to draw -> It does not work
4. Try to rotate and draw even further. The image is totally glitching

Pinta 1.7 on Archlinux

Revision history for this message
Cameron White (cameronwhite91) wrote :

Confirmed, it seems to only occur if I press Enter immediately after typing "40". If I e.g. switch focus to another widget in the dialog before accepting, the results are correct.

Changed in pinta:
milestone: none → 1.8
status: New → Confirmed
Revision history for this message
Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
Revision history for this message
Nico (nicohood) wrote :

I can confirm, that the fix works for me. Thanks :-)

Changed in pinta:
milestone: 1.8 → 1.7.1
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers