Moving pixel tool blurs selection

Bug #1904304 reported by Martin Howe
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pinta
Fix Released
Undecided
Unassigned

Bug Description

The move pixel tool blurs (anti-aliases?) the selection. This occurs whether you select a part of the current layer or move content that has been pasted in as a new layer. It gets pasted in OK, but blurs when moved. This is after a fresh install of Pinta 1.7. Please find attached a sprite being edited for a video game mod; a part of the image is copied, pasted in as a new layer, and gets blurred as soon as it is moved.

Revision history for this message
Martin Howe (martinhowe426) wrote :
Revision history for this message
Cameron White (cameronwhite91) wrote :

Confirmed, this behaves differently in v1.7 versus earlier versions. I traced this back to https://github.com/PintaProject/Pinta/pull/129, so probably what's happening is that the selection is being moved by a subpixel amount

Changed in pinta:
milestone: none → 1.8
status: New → Confirmed
Revision history for this message
Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
Revision history for this message
Martin Howe (martinhowe426) wrote :

Just built and tested this - working OK now. Thanks very much for prompt action :)

Changed in pinta:
milestone: 1.8 → 1.7.1
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers