Expand Canvas when pasting image shrinks the dimension it is smaller on

Bug #1883623 reported by 5lood237
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Cameron White

Bug Description

1. Have a canvas size, let's say 500x500.
2. Copy and paste or import an image that is smaller in one dimension but larger in the other dimension, let's say 300x600.
3. Click on "expand" canvas when prompted.
4. Expected: canvas expands to 500x600. Actual: 300x600.

Paint.NET does it the expected way, which is expanding only dimensions that need to be expanded.
This is a problem because when I am working on a project, and have images in the background, "expanding" the canvas currently crops the project.

Version: 1.7
OS: Manjaro KDE x86_64

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Cameron White (cameronwhite91) wrote :
Changed in pinta:
milestone: none → 1.7
status: Confirmed → Fix Committed
grofaty (grofaty)
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers