brush can draw outside of the selection

Bug #1775709 reported by Mikhail Lezhnin on 2018-06-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Cameron White

Bug Description

Pinta 1.6 on Ubuntu 18.04

Select any area you want;

Choose the Paintbrush tool;

Set the brush width to 1;

Slowly draw outside of the canvas area.

This would color distinct pixels (as if using the Pencil tool).

Mikhail Lezhnin (mike239x) wrote :
Cameron White (cameronwhite91) wrote :

I can reproduce with the latest git build.
The key seems to be moving the mouse very slowly, probably triggering a case where only one pixel gets drawn instead of a line

Changed in pinta:
importance: Undecided → Medium
status: New → Confirmed
Cameron White (cameronwhite91) wrote :

Same thing happens for the Pencil tool when clicking outside the selection

Cameron White (cameronwhite91) wrote :
Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
milestone: none → 1.7
status: Confirmed → Fix Committed
grofaty (grofaty) on 2020-08-05
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers