Addins wont install because they require the unreleased v1.7

Bug #1580205 reported by Jamie Roberts on 2016-05-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Robert Nordan

Bug Description

Some of the Addins, (dither effect is an example) wont install in the current release (1.6) with a message saying pinta 1.7 is a dependency

Incompatible plugins either shouldn't be listed, should be greyed out, or as an improvement, could inform the user that Pinta has an update available and let them upgrade to the newest version and install the plugin. In this case though there is no 1.7 release so this is confusing to users.

Or the repo isn't giving the appropriate version of the plugins to match the version of Pinta installed

Jamie Roberts (jamieisboss) wrote :
Robert Nordan (rpvn) wrote :

This is in a way a dupe of #1575875, but you raise a fair point that the add-in manager should be able to filter out add-ins that it can't satisfy the dependency of. We should look into if we can set a filter in the add-in installer dialog to do this, otherwise we may have to use different repos for different Pinta versions. That would complicate the maintenance of the add-in repo on github, although we could mitigate that with better tooling.

Robert Nordan (rpvn) wrote :

Of course, the first way of fixing it wouldn't help users on 1.6, and the second way would likely break all plugin installing for Pinta 1.6, even the functional ones. (Unless we work around it by saying that repos without version numbers equal 1.6 and everything after that has to be versioned.) Yay for backwards compatability!

Changed in pinta:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Robert Nordan (rpvn)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers