Drag and drop unhandled exception

Bug #1508777 reported by Koay Chiang Teik
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Pinta
Undecided
Unassigned

Bug Description

As summary above, Pinta does not crash, all is still ok, so far.
Not giving new users the best first impression at all.

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentOutOfRangeException: must be greater than 0
Parameter name: denominator
   at Pinta.Core.ScaleFactor..ctor(Int32 numerator, Int32 denominator)
   at Pinta.Core.DocumentWorkspace.WindowPointToCanvas(Double x, Double y)
   at Pinta.Gui.Widgets.PintaCanvas.<.ctor>b__4(Object sender, MotionNotifyEventArgs e)
   at Gtk.MotionNotifyEventHandler.Invoke(Object o, MotionNotifyEventArgs args)
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.Delegate.DynamicInvokeImpl(Object[] args)
   at GLib.Signal.ClosureInvokedCB(Object o, ClosureInvokedArgs args)
   at GLib.SignalClosure.Invoke(ClosureInvokedArgs args)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)

Revision history for this message
andrea.iacoponi@gmail.com (andrea.iacoponigmail.com) wrote :

Issue confirmed on Ubuntu 16.04.
Usually Pinta cannot handle more than 5-6 dropped PNG images before it reports the message error.
Error message is displayed several times: click on the OK button does not dismiss the message. Every user action on the program window multiply the message (see screenshot).
Once the error was displayed there is no way to recover Pinta control: the user has to kill the process.

Revision history for this message
grofaty (grofaty) wrote :

I can also reproduce the problem. I did the following:
1. Create some .png image and copy it multiple times. I have created 80 images.
2. Make Nautilus file manager and Pinta both visible like half of the screen.
3. Select all of the .png images and drag them to Pinta.
4. Pinta crashes with error message from bug report above.

I have also tested on Pinta 1.7-development from PPA and crash does not appear any more. It looks like this problem was already fixed in development.

You can do one of two ways to get this updates:
1. Install Pinta from pinta-daily PPA: https://pinta-project.com/pintaproject/pinta/howto/installing-pinta

Note: Above means it get get ugly if some development commit makes some regression bugs.
or

2. Download development version zip file and extract. You can do this without effecting existing Pinta or any other program on your system. Do the following:
a) From https://pinta-project.com/pintaproject/pinta/builds download latest working zip file (currently this is 1.7.0.232).
b) Extract zip archive.
c) In terminal execute command:
cd pinta
mono Pinta.exe
d) Check the Help | About menu if there is "1.7.xxx" displayed.

As stated above this is not going to effect existing official Pinta 1.6 version on your system or having no negative effect on your existing system.

If you don't like this new 1.7-development version you can just delete "pinta" directory.

Can you please test if this problem is solved in your environment in 1.7-development version.

Changed in pinta:
status: New → Confirmed
Revision history for this message
Cameron White (cameronwhite91) wrote :

I think https://github.com/PintaProject/Pinta/commit/196a93198e6a2b628fe7cad7fd037c4cf7eb9f55 fixed this. I can reliably reproduce this in 1.6 with the steps in comment #2, but this doesn't occur in 1.7

Changed in pinta:
milestone: none → 1.7
status: Confirmed → Fix Committed
grofaty (grofaty)
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers