Resize selection handle not showing up

Bug #1473430 reported by Gina Song on 2015-07-10
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

Shows up fine when I select it using Rectangle Select, but the handle doesn't appear when I copy+paste a new image into an another image.

Using Pinta 1.6

Cameron White (cameronwhite91) wrote :

After pasting you are put into the Move Selected Pixels tool, which doesn't have selection handles. The problem is that if you then switch back to a select tool the handles don't appear

Changed in pinta:
importance: Undecided → Medium
status: New → Triaged
tags: added: selection-tools
removed: handle resize selection
Mikhail (mikhaildd) wrote :

Seriously? A couple of years since this bug report and you have not fixed it??? What the hell is going on in this project?

canselcik (selcik-can) wrote :

Incredible that this feature to this day still doesn't exist. I was excited about using Pinta since it is a lot quicker to launch than GIMP and had the basic feature set I needed to edit a screenshot but unfortunately like many others, this is a deal-breaker for me.

I'm going to have to look into using Krita or running Paint.NET under Wine.

canselcik (selcik-can) wrote :

For anyone else ending up here, there is a PR in the GitHub repo for this problem, addressing the issue. From 2015, and it is still not merged in 2019.

https://github.com/PintaProject/Pinta/pull/105

Mark - Syminet (mark-syminet) wrote :

Same here, uninstalled as this is rather like a text editor where the space bar has been disabled.

Cameron White (cameronwhite91) wrote :

I think there may have been some confusion about which issue was discussed in this bug report.
https://github.com/PintaProject/Pinta/pull/138 recently added the ability to resize while in the Move Selected Pixels tool.

There is still a bug (comment #2) where switching from the Move Selected Pixels tool back to a Rectangle Select tool does not update the selection correctly.

Cameron White (cameronwhite91) wrote :

The issues with switching back to the selection tools after using either Move Selection or Move Selected Pixels should be fixed by https://github.com/PintaProject/Pinta/commit/9c0e401b72bcda5faad7ac051ecf6ab097792922

Changed in pinta:
milestone: none → 1.7
status: Triaged → Fix Committed
grofaty (grofaty) on 2020-08-05
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers