Rectangle Select with Shift key and selection is not displayed

Bug #1426660 reported by grofaty on 2015-02-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

Pinta dev. 1.6.0.110:

1. Rectangle Select.
2. Draw selection on canvas and don't release mouse yet.
3. Press Shift key and continue with rectangle selection what happens square selection is performed. Works as designed.
4. Release mouse key.
5. Press Shift and hold. Draw selection. Blue rectangles are displayed, but lines for square are not present. Problem.

The same problem with Ellipse Select.

Cameron White (cameronwhite91) wrote :

The Intersect mode is triggered by Shift + Left Click, so it conflicts with the regular behaviour of holding the shift key to perform a square selection. This requires updating translatable strings, so it'll need to be fixed for 1.7

Changed in pinta:
importance: Undecided → Medium
milestone: none → 1.7
status: New → Confirmed
tags: added: easy-to-fix
Cameron White (cameronwhite91) wrote :
Changed in pinta:
status: Confirmed → Fix Committed
grofaty (grofaty) wrote :

I tested this in 1.7+r1117-202007290048~ubuntu18.04.1 but step 5 still does not work.

Changed in pinta:
status: Fix Committed → Confirmed
grofaty (grofaty) wrote :

Additional note:
a) I have reverted status of bug to Confirmed, so that we don't lose track of it.
b) This problem also looks like a duplicate bug report of bug 1452607.

Cameron White (cameronwhite91) wrote :

I don't think this is a duplicate of bug 1452607 - that issue is for the Rectangle tool, not the Rectangle Select tool.
The rectangle select tool does work correctly for me now when holding Shift before pressing the mouse button, so I think the bug has been fixed?

grofaty (grofaty) wrote :

I now retested this problem with 1.7+r1120-202007292146~ubuntu18.04.1 and I can confirm this problem is fixed. I was not able to reproduce yesterday, because you have committed fix in #2 after Ubuntu 18.04 daily PPA was created, so I was required to wait another day.

P.S. Sorry about "duplicate bugs" confusion, yes there are two separate problems.

Changed in pinta:
status: Confirmed → Fix Committed
grofaty (grofaty) on 2020-08-05
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers